AAC files not showing up in the Music Library

  • 21 June 2023
  • 4 replies

Badge +1
  • Avid Contributor I
  • 10 replies

According to the supported audio formats it should be possible to add AAC files to the Music Library.

I’ve added a directory containing AAC files, but they don’t show up in the music library.

so far I’ve tried:

  • different kinds of folders (network shares, NAS, Music folder in Documents)
  • added metainformation to the AAC file using Mp3tag
  • downloaded various AAC sample files for testing

When I add a mp3 file it will show up, but no AAC


I’ve found similar topics while searching for a solution, but none with a solution.


So, is somebody able to select AAC files from their music Library ?

Is Sonos supporting AAC files in their music library, at all ?


Best answer by Jamie A 22 June 2023, 14:26

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

Userlevel 7
Badge +16

Hi @olluz,

You are correct that we support AAC files for Music Library, so I’m not sure why you aren’t able to see your files.

When you add new files or folders, you’ll need to re-index your music library. You may have already tried this, but I don’t see it in your list of troubleshooting steps so this would be the first step.

It’s possible the files you’ve added have DRM protection which is why they aren’t showing. This issue most commonly affects music purchased from iTunes before they switched to DRM-free music however iTunes Match allows you to upgrade your music to a DRM-free version. Otherwise you’ll want to reach out to Apple or whoever you’ve downloaded the files from to check if there is DRM and if there is a DRM free version for your Sonos Music Library.

Lastly, I would check if you have hit the 65,000 track limit for a Sonos Music Library. This limit can be reached by either track count, or by memory usage and the memory limit can be reached prior to 65,000 tracks if there is a large amount of metadata per track. If you have reached the limit, a service such as Plex will allow you to continue adding your own music to Sonos without the 65,000 track limit.

If these steps don’t help, I’d recommend reaching out to our support team for further assistance, as they have the necessary tools to troubleshoot this issue with you.

I hope this helps!

Same here. Reindexing doesn’t help. If I rename the file to MP3, then it shows up in the music library but I get a playback error (701).

Output from “ffmpeg -i” for the file:


Userlevel 7
Badge +23

Same here. Reindexing doesn’t help. If I rename the file to MP3, then it shows up in the music library but I get a playback error (701).

Output from “ffmpeg -i” for the file:


Looks ok to me, but as a test have you tried re-encoding the file from fltp to s16? Sonos don’t specify the details of exactly what AAC they support, maybe fltp is the problem?

ffmpeg does not seem to support s16 for AAC. Tried “ ffmpeg -i a.aac -sample_fmt s16 a_s16.aac”, but see also (fltp seems the only sampling format supported for AAC) and .


Thus, don't know how to do the test.