App wifi drops off iPhone iPad Sonos plays on

  • 14 January 2017
  • 7 replies

Hi, I have Sonos controller app on iPad and iPhone. I have a sonos bridge connected to a home hub 3. I regularly - several times a day - loose connectivity with the sonos app - it just says searching for sonos system. This will happen although the sonos components are happily still playing music. The only way to get connectivity back again seems to be to either reboot the router or switch wifi off and back on again on the ipad/iphone. It's very frustrating.

Have there been software updates recently that might have screwed the connectivity up? Up to about a few weeks ago never had this problem


Best answer by Jabba1980 15 January 2017, 22:00

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

My wife has a similar issue on her iPhone (6) however it rarely connects and is always looking for the Sonos system. However my iPhone (7) works fine and I have no issues using Sonos from a MacBook Pro. This seemed to have happened after a recent update. Interestingly, she can play music through Spotify to the various rooms in the house, but not directly from the Sonos app.
Do you have a dual band router? If a phone connects to tbe 5GHz network then (depending on the router) Sonos may become undiscoverable.
Hi John, I assume you answer was for Stephen however, I have a Cisco Meraki access point - had one SIDD working for years, Dual band with band steering. Interestingly, I've created a new SSID, 5GHz only and so far things look ok. So possible faulty 2.5GHz aerial on my wife iPhone phone... or a strange bug as Sonos is the only service she has connectivity issues with on the home network.
The WAP isn't a powerline wifi extender is it? They have been particularly known for causing problems with controllers.
Userlevel 2
Badge +2
I've recently had an issue after upgrading to ios 10.2. All devices that are still on 10.1 work fine, devices that have been upgraded all intermittently get the message " need to be connected to a wireless network to use Sonos..."

The fix for me on the 10.2 devices was to disable Wi-Fi assist. (Settings > Mobile Data > Wi-if assist)

My view is that the sensitivity of Wi-fi assist has changed in the latest update and is causing intermittent issues with the iOS controller.
Userlevel 5
Badge +11
On any BT newish hub, disable smart set up and any access restriction system on your router.
I've had similar problems where I could only find the sonos app working on my iPhone if I stood 6 feet away from the router. Before I could be 2 floors up and still get reception! It seemed to start after the Jan update to the Sonos app but it could also have been the IOS 10.2 upgrade. I've tried Jabba1980's disable WIFI assist and it seems to be working again. Thanks.