Answered

Android app shows empty queue each time started up

  • 28 February 2023
  • 50 replies
  • 704 views

Userlevel 5
Badge +8

When I start up the Android app it keeps showing the queue screen which is empty. It does this if the room that is playing is showing full screen but not if the playing is minimised and showing the rooms instead - hopefully that makes sense.

So if I close the app with the playing showing full screen, it will open full screen the next time and immediately shows the empty queue. If I close the app showing the rooms with the playing part minimised, it doesn’t open the queue screen when I start up the app but as soon as I maximise the playing part of it, it shows the queue screen.

There’s nothing in the queue and I just mainly listen to Planet Rock Radio which is still showing in the playing part when I start the app up.

The queue has been empty for many months and I’ve not used it for many months apart from having to keep close it when it opens by itself.

 

icon

Best answer by Corry P 4 August 2023, 15:29

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

50 replies

Userlevel 1

Same here! It just recently started and is extremely annoying. I try to back out of the app and it pops up at least 2 more times before it backs out. I thought maybe an uninstall and reinstall would help, it did not. Came here hoping to find a fix.

Userlevel 5
Badge +8

Once again - thanks for your time and help with this, much appreciated.

 

Userlevel 7
Badge +18

Hi @JohnG666 (& @ErikaF2009)

Thanks for your post!

I was able to reproduce this on my system/phone, and I have reported it.

However, as with most issues, the best traction is gained when the case count goes up - I would encourage you to call in and report this. Thank you.

Edit: But please don’t expect an immediate resolution.

Userlevel 7
Badge +18

Hi @JohnG666 

We consider this issue resolved. Therefore, we are no longer making any effort to fix it - why would we?

As you are continuing to see this issue, please get in touch with our technical support team to report as much - you seem to be the only person still reporting that you have this issue, so if you don’t report that you are still affected by it, who will? 

I would recommend that you submit a system diagnostic within 10 minutes of experiencing this problem, and call Sonos Support to discuss it. Just an anecdotal post doesn’t supply them any real information that they can chase, especially as it may be a local issue, and not a problem with the Sonos software itself. 

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your Sonos system and network. 

Userlevel 7
Badge +18

Hi @JohnG666 

I can only apologise for the trouble you had, but I have to confess that even after reproducing the issue and letting you know, when it came to recording a screen capture, I was at first unable to do so as I kept trying to capture the Queue showing after re-opening the app, rather than when swiping up - I was still partly convinced that that was the issue I was trying to reproduce. And I have a lot more spare time than the average telephone agent in which to do this kind of thing - I’m not trying to make excuses, just trying to illustrate the cognitive dissonance that the agents you were speaking to probably had, especially if they were just referencing the existing documentation on the matter.

Hopefully, we’re all on the right path now.

Userlevel 1

I have experienced this for about the past week as well. It is a highly annoying issue, and I can’t imagine Sonos believes people want to open the app and dismiss the queue each and every time they open the app. Generally my queue is empty because I usually stream radio stations. But there it is, an extra step I have to take every single time I open the app. I would like the app to open to a different screen than that one. That one is not in any way helpful to me, and probably not to a lot of other users.

Maybe I’m misunderstanding the comment from Sonos, but it sounds like you are aware of the issue, but you would like us to keep asking you to fix it? You need numbers to convince you there’s an issue you already know about? What??

 

Userlevel 5
Badge +8

Excellent thanks for letting us know :)

I will try and find the time to report this as well then.

 

Userlevel 1

Thanks! I will also call Sonos support.

Userlevel 7
Badge +22

My knees and back were not happy power-cycling my Sonos, added these and things are much easier.

https://www.amazon.com/gp/product/B07KFMNJLH/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&th=1

Userlevel 5
Badge +8

I am currently speaking to technical support.

It seems it doesn’t occur on his android device but it happens on both my android phones every time.

 

Userlevel 7
Badge +18

Hi @JohnG666 

That’s another issue I have. I changed the email address associated with my Sonos system and also log in to these forums with the new email address but the email notifications are still going to my old email address.

Okay. I’ll send you a Private Message regarding this - please keep an eye out for it.

Userlevel 7
Badge +18

Hi @JohnG666 

I’ve updated our records, and as a result, you should get a notification that I have mentioned you in this thread.

I hope this helps.

Userlevel 5
Badge +8

As an update and reminder to myself, I have sent 2 screenshots to support regarding this issue as requested.

 

I have the same issue lately, very annoying 

Userlevel 7
Badge +18

Hi @JohnG666 

It never happens the first time you open the Sonos App.

On first opening, make sure the Now Playing is minimised.
Then close the app.
Then open the app and the Now Playing will be minimised.
Swipe up on the Now Playing (tapping the Now Playing does not have this issue)
Notice the Queue screen
Now if I keep closing the queue screen, minimising the now playing, closing and opening the app it will continue to show the queue screen when swipe up on now playing.

 

I’m sure you’ll be glad to hear that by following the above steps exactly, I am able to reproduce the issue you’re having on my own phone. I will report this to a colleague, but considering that if I don’t follow these steps exactly it doesn’t happen, my advice to you in the meantime is not to swipe Now Playing - only tap it, and you shouldn’t be bothered by this issue any more.

I was able to record a screen capture of this happening - no need to supply your own, thanks.

Note, however, that this is not the issue that was previously described and fixed - that issue was about the Queue showing when opening the app, not when just sliding the Now Playing screen up.

I hope this helps.

Userlevel 7
Badge +18

Hi @mcri 

As with all issues, priority is ascertained by how many people get in touch regarding the issue. For this reason, I was encouraging anyone affected by this issue (as I do with all other issues not caused by local conditions) to get in touch as the number of people getting in touch regarding a particular problem will raise the priority with which it will be addressed. 

If you don’t have the time nor inclination to do so, that’s fine - with this particular issue, I have a feeling it will be addressed sooner or later anyway.

Incidentally, as you are finding it very annoying, please be aware that the queue only appears when opening the app if the app had the Now Playing screen fullscreen-ed when last used. If you keep the Now Playing screen “minimised”, you shouldn’t see the queue when reopening.

I hope this helps.

Userlevel 1

I called Sonos. The tech I talked to is unaware of this issue and tried to blame it on Sirius, as that's what I listen to. It's not Sirius. Sonos opens the empty queue and then I minimize it and it opens the current channel playing on Sirius, then I back out of it to get to my channel list and the empty queue pops up yet again, back out of it and then it goes to my channel list. Sonos was of no help. Told me to reboot my router, my extender, my Sonos speakers (all of them), and then finally my phone. Also suggested a factory reset on my phone. Um no…

Very disappointed with their tech help and still annoyed w the app. Also, it's only doing it on my phone and not on computer so he thinks it's my phone. No, it's the app and it needs a fix.

same issue, very annoying, as is the amount of time spent troubleshooting this and numerous other system issues. don't buy sonos, not worth the headaches

Userlevel 7
Badge +15

Hi @JohnG666,

Thanks for bringing this to our attention, I’m sorry to hear that you’ve gone this long without contact from our team, we aim to do better.

I’ve located your case in our system and have flagged it with a colleague. They should be reaching out to you soon, if not today then tomorrow.

If there is anything else you’d like to bring to my attention, please reply here.

I have the same issue.

Had an update yesterday and thought it was a fix, but no it's still happening.

I find it incredible that the money we spend on the hardware and then we are treated like the previous poster (EricaF2009). Your App needs fixing now.

So are you saying that if one customer has a problem and no one else has that problem it won't be fixed because not enough people complained?

You are aware of this problem, you can replicate the problem, so fix the problem please.

I'm beginning to lose all faith in Sonos because of this attitude.

We are customers and deserve better from you!

 

Userlevel 4
Badge

Me too. Nothing in queue. I listen to quite a variety of things - SomaFM, Tidal, TuneIn radio stations…

I've only used the queue… Twice? For specific local music playlists for a couple of friend's birthday parties, but not for… A year? Maybe more…

Quite annoying. Only started a month or so ago with an update.

If there was the ability to revert back one
 update I absolutely would…

 

Please fix!

Userlevel 5
Badge +8

I haven’t heard anything from Sonos. Other people have though looking at the replies above.

 

It’s the exact same problem as I originally stated. It’s never been fixed for me

 

Userlevel 5
Badge +8

Hi @JohnG666 

We consider this issue resolved. Therefore, we are no longer making any effort to fix it - why would we?

As you are continuing to see this issue, please get in touch with our technical support team to report as much - you seem to be the only person still reporting that you have this issue, so if you don’t report that you are still affected by it, who will? 

 

I consider this issue as never been fixed and only came back to this thread out of annoyance. I’d not even seen your previous post where you claimed that it had been fixed.

I found something on a different thread that mentioned this happening only when launching from a widget. For me the queue launches every time when loading the app from the widget. If I launch from the app icon, no queue screen shows. Not holding out for a fix to this anytime soon since IOS gets all the love first.