Sonos won't connect to TP-Link Archer AX6000


Recently changed my router from a Linksys WRT1900ACS running Luci firmware to a TP link Archer AX6000 - my Sonos speakers refuse to connect to the 2.4GHz wifi on the AX6000. 

Sonos kit:

2x One, 1x One SL, 1 x Play:1, 1x Ikea Symfonisk bookshelf - I’ve upgraded to S2.


All my non-Sonos 2.4GHz kit works fine with the new router. I’m running with duplicate SSIDs for 2.4 and 5 GHz I’ve tried with and without smartconnect. I’ve also tried setting up a totally new 2.4 GHz SSID. I’ve tried turning AP isolation on and off (usually off on my non guest networks). Speaker location isn’t an issue here - I’ve been trying the below with the speakers a short distance from the router. 

Tried the following via the app:

Going through the ‘changed router/wifi settings’ journey

Wiping the app and factory resetting the speakers.

Joining the speakers using the ‘accessory configuration’ process (Apple native)

Joining the speakers using the ‘select SSID and type in password’ process

Connecting one speaker with a wired connection (this all works until I disconnect the wired speaker at the end of the process.) I didn’t check whether the wireless speakers connected over Sonosnet were also visible as airplay devices. I don’t want to run with one wired sonos (this will involve digging out my old powerline ethernet kit to keep the speakers in the same places - I’d rather not).


No matter what the process, the Sonos app generally fails at the step of adding my wifi network (in a couple of cases the app appears to complete this process but then I can’t see any speakers).

Interestingly the speakers are connecting to the router - I can see them in the list of DHCP leases, and I can ping them, they just aren’t visible in the app. Makes me think there is some kind of peer to peer comms thats not working between the speakers/phone running the app. 


In the end, I reconfigured the old Linksys router to be an AP (no firewall or DHCP services) added a different SSID and plugged it into a TP-Link LAN port. The Sonos speakers work fine with that, only wrinkle is that the phone running the Sonos app has to be on that new SSID to add new speakers - it can be on the main SSID (same subnet) to use Sonos (either natively or Airplay2).


So I have things working again, but I don’t want to run both routers long term. Any ideas?



This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

14 replies

TP link have provided a beta firmware which appears to fix this. Sonos kit all connected to the AX6000 over 2.4G and so far stable.


Seem to have been a few issues introduced in a recent firmware release.

Userlevel 4
Badge +12

Hi @Justin.W, sorry for the late response, thank you for reaching out and welcome to the community.

I would like to confirm after the firmware update for the Tp-Link Archer, the Sonos speakers are now connected?

If so, I’m glad it’s now working. Whenever we change to a new router, this is how we Connect Sonos to a new router or WiFi network.

If you have other concerns, feel free to reach out.

Correct - its been stable for just under a week since I put on the beta firmware. They haven’t been forthcoming on what changed in the beta, or on any plans to take it GA. There seem to be a few issues with the recent base firmware that they are dealing with.

Userlevel 4
Badge +12

Hi @Justin.W, thanks for the update.

Good to know, just reach out if you have other concerns.


Hi @Justin.W , I seem to be having the same very annoying problem after upgrading my network. How did you get the beta firmware? Are things still working for you?


I posted the same original issue on the TP link community site too. They posted the firmware on there. The link to the thread is here, you can find the link to the Ax6000 beta firmware a couple of posts down

its been ok so far if I dont touch the settings on the router.  For example, I made a change to the 5GHz network which shouldn't have impacted 2.4 GHz and lost all the Sonos stuff again. Took some fiddling with the router settings to get it back again. I’m hoping TP link release more fixes. 

good luck with yours. 


@Kyle A Same issues here FWIW; you might want to consider putting this router on a list of known-incompatible models for the moment so that others don’t have this experience :(


Sonos support had me change the 2.4ghz band to a manually-selected channel which seemed to have fixed the connection problem for the last few weeks, but woke up this morning and my 2x Ones were not showing up in the iOS app (Beam has consistently been solid; maybe there is something different about the way the Beam handles network connectivity vs. the Ones?). For whatever reason, I was able to see & group the 2x Ones on my laptop’s Sonos Controller, and they then subsequently appeared in the iOS app. Frustrating that a brand new, very expensive router is acting up so much with Sonos but my years-old inexpensive one was super solid.

Userlevel 4
Badge +12

Hi @eab6287, thank you for reaching out.

For a router to be incompatible the Sonos shouldn’t be able to connect to it at all.

In this case, Sonos speakers are just having connectivity issues. 

There’s not much difference for network connectivity between the Beam and the Ones.

The only difference is that the Beam handles the connection for Surround and Sub bonded to it.

I’m curious, can you take a diagnostic on the system; so we can take a closer look.



@Kyle A Thanks for the quick reply! Just sent a diagnostic (conf 602407608). In case it’s helpful context, I’m using the 3 speakers in a 600 sqft apartment, so distance to the router is a non-issue but interference could be (many neighboring networks); perhaps that’s what was addressed with the manual channel setting (although you would think such a high end router could handle something as simple as selecting a reasonable channel).

Userlevel 4
Badge +12

Hi @eab6287, thank you for the update.

I checked the diagnostic, all speakers are connected with minimal interference. 

The agent changing the channel settings of the router from Auto is a good thing because the channels that are recommended are 1,6,11.

These channels have the least interference with one another. So preventing the router from changing the channel automatically; prevents it from using other channels other than the three.

Since you’re in an apartment complex, this article will have tips on Reducing wireless interference

I would like to check the router as well, could you please provide the model of the router.

It could be that the router has 2 bands 2.4 GHz and 5 GHz and the phone jumped from the 2.4 GHz to 5 GHz.

In this case, It can disrupt the Phone’s connection to the Sonos system. Also, our Sonos speaker can’t use the 5 GHz band from the router. 

If you have other concerns, feel free to reach out.





@Kyle A Thanks; I’m using the same router as JustinW (TP Link Archer AX6000). It is a dual-band model, with the speakers on 2.4ghz and most other devices (including the phone I use) on 5ghz. I imagine this is probably the case for most Sonos users, though (most devices will use 5ghz for the greater bandwidth) and at least in theory it shouldn’t be an issue for devices on the two bands to communicate with each other (certainly worked fine with my old router for years). 

However, it does seem that maybe the TP Link firmware is causing trouble with devices communicating across bands in this particular case...Hopefully they release an update which improves things soon.

Userlevel 4
Badge +12

Hi @eab6287, thank you for the update and sorry for the late response.

I see if that’s the case going through the thread @Justin.W mentioned can probably help.

However, I would suggest going to the manufacturer for an accurate answer to the firmware.

In any case, feel free to reach out with other concerns.



The original beta mentioned earlier in the thread (see the link to the TP forum) has been ok. Some issues with changing config breaking stuff, but stable if I don’t change things. (That said we did have some 2.4Ghz issues with laptops last week). haven’t tried the other beta yet - waiting for other reports. 

I do successfully have 2.4 and 5ghz on separate SSIDS now and phones on the 5Ghz can manage Sonos stuff on 2.4. 

I did find that I needed to lock the 2.4 to one of the non overlap channels (1,6,11) rather than let it Auto. 

Maybe you just should try to enable IGMP Snooping (not default enabled by TP-Link). Settings, Advanced, Network, IPTV, check “enable” IGMP Snooping.