Answered

New Asus RT-AX82U/AX5400 Router Sonos System Not Showing Any Recommendations?

  • 5 December 2020
  • 72 replies
  • 5932 views

Badge

Background:

Family Room: AMP w/Sonos ONE (pair as surrounds)

Backyard: Connect(gen2)

Asus RT-AX82U/AX5400 Router

After installing new router and updating the wifi settings, the Sonos App (S2) does one of the following: 1) stays grey and doesn’t show up 2) only shows the Connect 3) Works perfectly for 3-5 seconds and then the system dissapears.

I've gone in and adjusted the router settings as recommended in various help sections, turned off the auto-priority/QoS settings in the router, updated the channel to Ch6 within the 2.4 channel, did the whole direct plug ethernet cord into the amp, and ONE speaker to update the wifi information directly as recommended. Also rebooted all sonos products.

The only thing working right now is the family room because it feeds audio in from the TV.

Any recommendations or links would be helpful...spent the last few days becoming a fake fix-it dude.

 

Thanks!

icon

Best answer by Toad74 18 December 2020, 22:07

View original

72 replies

Userlevel 1

Thanks @controlav for pointing me in the right direction!!!

 

Rolling back the Asus firmware for my RT-AX82U router from

Version 3.0.0.4.384.10177

2020/11/26 

to 

Version 3.0.0.4.384.9948

2020/11/03 

has allowed all three of my SONOS speakers function as expected.

 

@controlav

Just use SonosNet (‘wired’) mode and avoid all these complications. 

My speaker is far away from any ethernet connections. Would one of these bridges solve my issue: https://www.amazon.com/Sonos-Wireless-Network-Discontinued-Manufacturer/dp/B000X1TS54 (i.e. connect bridge to ethernet and speaker to bridge)?

Note: the older Sonos ‘Bridge’ only works with an S1 System/App - it does not work with S2. An S2 system will work with its successor, the Sonos ‘Boost’ 

Userlevel 7
Badge +22

Asus seem to be unable to produce router software that is compatible with Sonos:

 

 

Badge

I returned the router and purchased an Archer AX-11000 from Costco. Zero issues and now I have super long range 2g band and two 5g WiFi bands. This thing is awesome.

I have been struggling for a week and thankfully came across this message and installing 

Version 3.0.0.4.384.9948

2020/11/03 works for me also!! 

Userlevel 7
Badge +22

I received words from an old Asus engineer. He told me that Sonos has been tinkering way outside the wifi standards and making use of unreliable protocol parameters since years back. Asus has since a long time discouraged wifi-product developers from making themselves dependent on these parameters.

Last year Asus rolled out firmware which effectively plugged these “holes”. For security- and stability reasons, they do not plan to reinstall those holes in the future. Instead, Asus leave it to any developers of wifi devices to follow protocol standards.

Personally, I think this says a lot. Sonos probably had some good coders employed a few years ago. They should have kept them.

This also explains all observations reported here in the Sonos discussion forum. I just ordered a pair of Apple HomePod minis.

I call BS on what this ASUS engineer claims. If there was a grain of truth in this, why would a factory reset of a router cause it to suddenly work correctly?

Add RT-AX58U to the list, bought a new router a week ago updated firmware connected everything including Sonos system. 

Devices show connected in router interface but wouldn’t stay connected to the Sonos App. Found this thread reverted to version 3.0.0.4.384_9918 from 11/03 and it’s working great now.

 

 

hi all, thank you all who contributed constructively here. I too have a Asus router AX88U and had dropped connections with my beam + sub + 2 SL Ones. it happens whenever i turn on my guest network. Even after i deactivate the guest network, the sonos will go missing. Never understood why. I tried all the solutions suggested here excluding rolling back the firmware. Nothing has really worked. But i tried to update my firmware to 

Version 3.0.0.4.386.42819

2021/04/29 

after the firmware update, i did a factory restore of my router.

I also deleted all my sonos speakers and re add them. 

So far so good. I have not tried turning on the guest network as i am tired of all these troubleshooting and my family have been complaining that i keep bringing down the internet/speakers to troubleshoot. haha. FINGERS crossed!

Userlevel 1

I just got a Beam, and router Asus RT-AX58u, the BEAM always disconnecting from wifi, I tried everything I read here on the Sonos community about Asus routers, especially the RT ones, I decided to update to the latest firmware so after the update same problems, beam disconnecting again...i read somewhere here to try a router factory reset, so I did that and BAM the Beam is working well, not disconnecting anymore.

I suggest you guys try this router factory reset after firmware update.

How can Asus, one of the largest router manufacturer, have such poor customer support.

One year of unresolved interoperability issues with Sonos is a shame.

This is my last Asus product ever! 

I’m a network engineer and using old router firmware just doesn’t sit well with me.  I bought this router because of its QOS function to help with my video conference calls.  Turning off QOS is not an option for me.

 

With that being sad I did try the suggested old firmware Version 3.0.0.4.384.9948 and it worked ok. Definitely way better than the newer firmware versions.  It still wasn’t 100% though, more like 90%. 

 

I ended up buying a Sonos Boost off ebay and everything is 100% now.  Its not the option I wanted to take but like I don’t like my Sonos not working.

 

edit:  im on the newest router firmware

Tried the latest, but it brought back the old issues. Rolled back to 3.0.0.4.384.9948 and its working again. Thinking of picking up a new router. The beta has some critical security needed for this router.

Good idea. I personally recommend the AmpliFi HD as it is super reliable, created by a highly regarded network company, and offers mesh extenders if you need those.

The AmpliFi HD has a buggy dual-band and doesn’t support WiFi 6. I literally just replaced it with an Asus RT-AX3000, which works perfectly with proper dual-band for all my devices, it easily pulls 700 mbps down throughout my house (over twice what the HD could do). Everything except Sonos works like a charm, so I think this is on Sonos.

Just wanted to thank the community here for finding this out. I was pulling my hair out trying to get everything to work; speakers kept dropping off, music services dropping off, and occasional playing would stop every 3 seconds.

 

I’ve reverted my RT-AX82U router to 3.0.0.4.384.9948 and it worked for me too. The SONOS support pages do suggest turning the AirTime Fairness setting to off (which is definitely the default in .9948 - not sure about others?), but I don’t think that works here.

 

If anyone does get success with a later firmware please re-post here. I’m not missing out on anything from the updates until the most recent beta’s security patch (9.0.0.4.386.41994) but I’m keen to get that in as soon as I can. I’ve emailed ASUS customer support but feel it unlikely I will get anywhere as they likely have raw performance as their target.

Just use SonosNet (‘wired’) mode and avoid all these complications. 

Just wanted to say that I updated via the router interface ‘button’ to BIOS Version 3.0.0.4.386.43129 (2021/05/14), then performed a factory reset, re-entered the same SSID and password details and so far (an hour in) everything is running smoothly. For those that were holding back on the November release this might be a chance to patch up and see if it works for you too.

Userlevel 1

Very much the same issue here with this same router.  Has there been any progress on ising this router?

OK I’ve finally had some joy here. I actually bought a Boost (which I also couldn’t get working - another story..). However, whilst working through the Boost issue, the Sonos tech on the phone asked me if it was viable to plug one of my devices directly in to the router and switch the SonosNet to wired.  We tried this and all of the Sonos devices (old and new) happily joined again - and stayed joined.

I am now running the latest Asus firmware and all working ok.

As for the Boost - it’s going back but I guess if we ever move to a larger house I may need to revisit.  For now though all good.

@bruvva74 What does “switch the SonosNet to wired” mean? I’m not familiar with the SonosNet concept. Is that some kind of setting in the Sonos app? Also, did you have to go through this wiring process for each of your Sonos devices, or just the one mentioned above? Could you please explain?


He means he wired one speaker to his router to create SonosNet. In a wired setup, the wired product will broadcast a dedicated wireless network (SonosNet) that your Sonos products will use. Surround speakers or Sub cannot be used as the single wired product.

You do not need to wire all your speakers, one is sufficient, but having multiple sonos speakers wired to the router can result in a more stable system. A Sonos Boost can also be used to create SonosNet where no speaker is near the router.

Thanks for responding to Arrbie Mr. T - couldn’t have put it better myself. :)

Userlevel 6
Badge +17

Hi @Long Beach Cliff May.

Welcome to the Sonos community and thanks for bringing this to our attention. Allow me to share with you some workarounds on how to work things out.

 Hi @Long Beach Cliff May .

Welcome to the Sonos community and thanks for bringing this to our attention. Allow me to share with you some workarounds on how to work things out.

​Our engineering team have been made aware of some ASUS RT series router that causes some issues with Sonos and has provided some work arounds. Let me share with you these troubleshooting steps to get things sorted.

  • First is we need to download the Asus App through this provided link.
  • Once the Asus app have been downloaded, Let us connect to the Asus router’s WiFi network and open the Asus app.
  • On the Asus app look and tap on devices.
  • Scroll to the blocked devices and look for Sonos and tap on it to open a new menu.
  • On the newly opened menu, look and tap on Disable Block Internet Access.

I hope this helps.

Please keep me posted on the progress and let me know how it goes. Here in the community, everyone is welcome.

Thanks,

Just to add regarding sugestions of turning off QoS and Wifi fairness.

Wifi fairness was disabled for both 2.4Ghz and 5Ghz by default.

I initially logged into my RT-AX82U (latest firmware: 3.0.0.4.386_43588) using the (iOS) mobile app. When I searched for Qos it showed a setting and I marked both bands as disabled. Still couldn’t use / register my Sonos Play 1’s.

I’ve since logged into the router from my PC and when you go to router.asus.com there is an menu items for Adaptive QoS as below. This was still turned on. I have now turned it off as below & have successfully added my first speaker back to a new system (having reset the iOS Sonos app). Worth checking both settings or, ultimately, don’t trust the Asus mobile app! 

 

 

Having the exact same issues, I have not tried changing the firmware, but I’ll have a look to it tonight.

@Paul A Your recommendation are not suitable.

No one said the device were blocked by the router. What you suggest would fit if the user would have “Blocked” the device at some point which is not the case.

The devices are not blocked, at least not from a user point of view, but the router might be blocking some port, or acting on the channel etc in a way the interferes with Sonos...

Userlevel 7
Badge +22

I have a quick follow up, has anyone tried implementing a boost to their system?

Presumably the hard wired connection and dedicated separate network would allow all speakers to work?

just considering my options because I want to be able to use my system without having old firmware on my router!


I would just get a new router, clearly this Asus range has some major trouble with actually passing network packets in the correct manner and they seem incapable of fixing it.

An AmpliFi Instant costs the same as a Boost.

Hi @belgiumcookieman 

BTW Sonos team, https://support.sonos.com/s/article/41?language=en_US needs an update to reflect this clear incompatibility. 

 

Thanks for pointing that out - I’ll ask for the page to be updated.

To clarify, are you updating the doc because Sonos will not be able to work with Asus to fix the problem or is it a temporary placeholder? I would really appreciate it if Sonos were seeking a solution with ASUS and I would be also pleased to know that ASUS are making progress. Is there interest and resources to fix this issue?

We have an RT-AX82U router and were having the same issues too. As well as rolling back firmware, the new beta version  seems to work too - 9.0.0.4.386_41994

 

Tried the latest, but it brought back the old issues. Rolled back to 3.0.0.4.384.9948 and its working again. Thinking of picking up a new router. The beta has some critical security needed for this router.

Badge

Just joining the party and rolling back to 384.9948. Fingers crossed. 

I’ve lost a weekend faffing. So hopefully it’ll work.

Userlevel 7
Badge +18

Hi @belgiumcookieman 

Hi @belgiumcookieman 

BTW Sonos team, https://support.sonos.com/s/article/41?language=en_US needs an update to reflect this clear incompatibility. 

 

Thanks for pointing that out - I’ll ask for the page to be updated.

To clarify, are you updating the doc because Sonos will not be able to work with Asus to fix the problem or is it a temporary placeholder? I would really appreciate it if Sonos were seeking a solution with ASUS and I would be also pleased to know that ASUS are making progress. Is there interest and resources to fix this issue?

Lower down on that same page is a page specific to Asus RT series routers - I don’t know if you saw it. It still needs updating to include the factory reset. https://support.sonos.com/s/article/3668

Although that page doesn’t refer to the factory reset needed after a firmware update, I have seen internal documentation referring to it. I assume we’ve already been in touch with Asus regarding the issue, but I don’t have anything further to share. As there’s a reasonably simple workaround, it isn’t a priority for us (and there’s nothing we could do about it if it was). The only thing likely to hurry Asus (much like any other company) up on the matter would be increased contact volume from their customers.

Reply