Sonos Connect Line In dropping audio in and out

  • 18 January 2017
  • 7 replies
  • 773 views

When trying to stream normal audio from a Connect RCA line in to a remote Connect the audio drops in and out consistently. Numerous accounts of the same issue are in the Community but no solutions, not even adding the Boost works. Is the product just not able to handle streaming a line in without the drops?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

Userlevel 7
Badge +22
Adding a boost should help. Did you go into settings for the room line in and try setting to compressed audio and see if that helps.

I would submit a diagnostic with the boost hooked to router and post the diagnostic number here for a Sonos rep. to review your network. Submit diagnostic by going under settings...advanced.
All the replies in the Community indicate the Boost will not help and Compressing only adds a lot of Latency. Have you seen those?
Userlevel 7
Badge +22
I'm giving you advice from my experience not from some random posts.

The boost gets all music traffic onto Sonosnet and therefore you aren't sharing bandwidth with your home network and thus would make it less prone to having difficutlies with bandwidth like you are experiencing.
Understood. Already went to Best Buy and have a Boost here and about to set it up. Fingers are crossed as I really only want the Line In feature.
Userlevel 7
Badge +22
I would first add the Boost to your current wifi only network by going into settings ... add device. Once added I would then plug it into your router. Give system about 10 minutes to adapt and you should then be running in boost mode. Go into settings and adjust the wifi channel 1, 6, or 11 to one of the 3 not being used by your home router (and home router on one of the other 2). Keep the boost as far from your home router as cord allows (like it to be about 2 feet).

I have used a Google Chromecast dongle connected to my Play:5 line in - uncompressed - over Sonosnet with no dropouts.
Up and working now. Took about 15 minutes previously for the dropping out to start. Hoping for the best.
1. Should I have a Cat-5e between the Boost and the Connect into which I have my Line IN wired?
2. For Music Streaming, the Boost drags data off the 2G band on the router?
Userlevel 7
Badge +26
Hey guys, thanks for helping out Chris. I just want to add that line-in audio from one player to another is one of the top three highest demands of Sonos streaming. That audio has very high quality, and if you have any transmission issues, it can be unforgiving. To mitigate this, the BOOST (or having a wired Sonos device) is a good way to go, so that the wireless from your player doesn't go through the home traffic. Also, eliminating wireless interference can help a lot too.

There are two settings that make a lot of improvements in challenging situations. First off, the compressed change drops the line in audio format to a compressed format, it has less data and therefore transfers faster with more aptitude for recovery. Also, if you set the Line-In level to level 4 (Airplay) it increases the audio buffer for the Sonos line-in. It also increases the delay.

1. It definitely could help, but it isn't necessary as long as the CONNECT that's getting the audio isn't getting bad transmits over to the BOOST.
2. The BOOST is creating the Sonos mesh network for the other players. Each of those two are also broadcasting that same network to extend the mesh. They aren't on your wireless network at all when doing this, though your controllers likely are. Line-in is going to come from wherever the orignial source is, to the CONNECT, across the wireless to the other player. It won't be on your standard wireless network with a player or BOOST wired in.