Humming with New Sonos Port

  • 6 November 2021
  • 8 replies

Userlevel 2

I just bought the new S2-compatible Port to replace my old Connect. Unfortunately this makes my active B&O speakers start humming after the music has stopped. Very frustrating as this was not the case with my Connect. 

The issue is identical to a previous post, which is now closed. 


Any suggestions how to solve this issue?



8 replies

Any suggestions how to solve this issue?

Indeed. Follow the suggestions in the thread you referenced.

Userlevel 2

Thanks. Since the author of the thread didn’t reply I was unsure if this was actually a solution. 

could you please explain in more detail how I ground the assembly? A separate wire from the speakers? From the port? To where?



Often a thread author doesn’t post back unless the offered solution failed. 


As noted in the referenced thread, I found a simple solution by cutting the plug off an old RCA-RCA cable and finding somewhere to ground the exposed shield. Depending on your country you may be able to get a grounding plug which goes in a wall socket.

Be sure to insulate the core at the cut end so it can’t make contact with anything. It doesn’t matter which unused RCA jack you use on the Port.

Alternatively an off-the-shelf grounding plug might have a cable of its own with a crocodile clip on the end, which can simply be clamped onto an exposed RCA jack.

Userlevel 2

Thank you! Here’s an update:

Tried grounding; speakers, port and both. All resulted in less humming when the speakers were “off”. However it did also introduce more humming while listening to music, hence that wasn’t an acceptable solution. 

Instead I tried a shielded AudioQuest cable (with ground “forks”). Resulted in the loudest noise so far, with or without grounding. Because it was a sub cable? Should that matter? I mean the speakers are active…

Finally I tried the short RCA-cables included un the Sonos box (because of the short length only possible to try one speaker). Now the buzz is totally gone, both with the speakers active and inactive. The result is the same with one or two RCA-plugs connected (either only white to white or white+red to white+red)


This gives me two options:


  1. new better cables 1RCA-1RCA x2 (2-3 meter each). Suggestions? Will it solve my problems?
  2. purchase the Beolab Transmitter and connect it to the Sonos Port. This makes my Beolab Speakers wireless, and I won’t have to buy expensive cables. Somewhat concerned this solution will result in delay and sync issues though, but that’s only my gut feeling. 


Grounding can be a bit fickle. Too little grounding: hum, due to float. Too much grounding: hum, due to loops.

I can’t really comment further on your specific situation. My experience is anecdotal. Experiment. 

As for a wireless TX it might introduce noticeable delay, or it might not. It depends on the radio tech and whatever protocols are used over the top. The B&O docs might provide some insight. Does delay matter though? If the Port is playing alone then probably not. If you require sync with other Sonos players that’s a different matter. 

Userlevel 4
Badge +6

[Edit: Bunch of junk related to *old* Bang & Olufsen speakers deleted, sorry.]

If your speakers have both red&white RCA connectors, they are new-ish BeoLabs, therefore likely have TOSlink connectors too!  Consider getting a SPDIF (coax) -to- TOSlink (optical) converter for your Port.  No grounding troubles via optical cables!:grinning:  Beats WiSA hassles too; I would not recommend the Transmitter1 unless you have no other choice.  Bonus: Even a cheapo converter and 25’ cable will be perfectly OK, and cost much less than your “forked” (you said it @hoogey, not me:wink: ) Audioquest cable.

Userlevel 2

Thanks again!


That’s right. The speakers are new and have Toslink, see specs below. 


another advantage with the Beo Transmitter is its ability to adjust the sound level of a Beolab 19 subwoofer depending on how loud you play music. This is not the case with a wired solution. May have to try this. (And buy a subwoofer that I haven’t got yet…)

In the meantime I’ll try with different kind of cables :)



Wireless Power Link (24 bit / 48 kHz) WiSA (24 bit / 96 kHz)

Wireless Powerlink

Wireless Power Link (24 bit / 48 kHz) WiSA (24 bit / 48 kHz)

Inputs and outputs

2 x Power Link (RJ45) 1 x RCA (L/R) 1 x TOSLINK In: Sample rate 32k, 44.1k, 48k, 96k/PCM16-24 bit Out: Sample rate 48k/PCM 24 bit

Hmm… I have the same issue, I Think the reason is that the new port does not send power in the shielded part of the cabel…

and therefore it acts as an antenna, when the port is in sleep mode…

This will only happen, if the cabel between port and speakers is long

(mine is 10m)

Can we get the sonos port to start sending power in the cabel, when is sleepmode

as the old connect did...