Answered

Can't Disable Wifi from Ethernet Connected S1 Device


Badge

I have two Sonos Connect devices (in different rooms) running S1. Device A is connected by ethernet and B by wifi. RIght now, my router reserves bandwidth both for the Ethernet connection to A and for the Wifi connection to A, along with the wifi to B. (The router recognizes 3 Sonos connections.) The problem is the router partitions bit-speed, and I'm at the limit of what my ISP can do. So I want to make the A connection eithernet only, bringing down the denominator by one in the division of bandwidth. Sonos does have a setting for that, but when I disable wifi to A, mysteriously B disappears from my system. Can anyone help me fix this?

 

icon

Best answer by Jamie A 14 June 2023, 10:56

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

18 replies

Userlevel 7
Badge +15

Hi @Proteus,

The only reason I can think of would be that device B is too far from the router for a good connection and is using device A as a node to join the network. Disabling Wi-Fi on a Sonos product prevents the wireless radio on the device from communication with other devices, so disabling this on device A, means device B can’t communicate directly with it.

While this could be the case, I don’t think it’s likely and there may be another reason you’re running into this issue. I would recommend submitting two diagnostics, one with Wi-Fi enabled on device A, and one with Wi-Fi disabled. That way I can have a look to see what could be causing this issue.

You could also reach out to our support team for live troubleshooting, as they have the tools available to troubleshoot this issue with you.

I hope this helps!

Badge

Thank you very much for your support. Here is the diagnostic confirmation number for the system with A connected to ethernet and wireless, and B connected wirelessly: 1756853582. When I disabled wireless on A, not only did it lose B from the system, it also, strangely, disabled the diagnostic function. “Cannot send diagnostics at this time.” Really, it was such a paid reconnecting everything that I am not eager to try again without more advice as to what is going on and what might be done about it. I can tell you that everything works very well with these 3 connections, the only thing being that if I can find a way to have A connected by ethernet only, it would save precious bandwidth. Thanks!

WiFi should hardly ever be disabled on a Sonos device, whether it is wired or wireless. My guess is that you have not put your current WiFi details into Sonos. The system uses SonosNet instead once a Sonos device is connected by Ethernet. 

In the Sonos app, go into System, Network, Manage Networks and check whether your current network details are there.

If both A and B have their wireless enabled, one of them is connected to Ethernet, and the other is within range, neither unit will connect to or use any WiFi bandwidth. SONOS will build a private wireless mesh network, SonosNet. It would be best if your 2.4GHz WiFi segment uses 20MHz channel 1, 6, or 11. Usually it is best that SONOS uses a separate channel.

Badge

OK, when I go to manage network and click on SonosNet, it says it’s using channel 6. Is there something else I should do to make sure it’s a separate channel? Sorry, I have no tech knowledge on this stuff. My ISP diagnostic says the Sonos A and Sonos B are each wirelessly connected to the router, in addition to A’s internet connection -- it recognizes all 3. This means, according to the ISP technician, that the router is allocating bandwidth to A and to B, as part of an equal partition. That does seem useless, since you say Sonos actually isn’t using the home WiFi. But maybe there’s no way I can change it. I can live with it this way, but the waste of bandwidth implied by this allocation that isn’t being used is costly, since I’m up against limits. When there are too many devices on the WiFi, I get sound drop-outs on Sonos.

I can’t get my network details into Sonos. It rejects the WiFi password, even though I am giving it the correct one. That’s consistent with the idea that it’s not actually connecting to WiFi, which is fine by me. But it’s then a mystery, to me anyway, that disabling A’s WiFi breaks off B from Sonos altogether. Again, maybe I have to just live with this. Maybe the followup now is mostly to be sure SONOS is using a separate channel, as buzz suggests.

Advice very welcome here.

 

Since SONOS is on your network, the router will be aware of it because the SonosNet units have requested an IP address (using the wired connection). I don’t know what kind of reporting capability your router offers. If it offers separate reports for wireless and wired traffic, you’ll notice that when SonosNet is enabled, the wireless traffic associated with SONOS will be near zero.

Unfortunately, the SONOS option to turn OFF WiFi is misnamed because it actually turns OFF the unit’s radio for both WiFi and SonosNet. At this point the unit will work only while connected via Ethernet. 
 

There is a tendency to equate “wireless” and “WiFi” for consumer electronics gadgets. This is unfortunate, especially in this case, and very confusing for both the general public and the tech types.

SONOS is very different from typical home network clients because it needs lots of communication over the network — wired or wireless. There will be obvious traffic between remote music services and SONOS units, plus traffic between controllers and SONOS units, traffic between SONOS units and local disk drives and computers that store a music library, and SONOS units as they share data among themselves.

Let’s consider attempting to play track yyy from music service zzz. The phone/pad/computer running a SONOS controller will communicate with one of your players and request that yyy be sent to one of your players, not necessarily the player that the controller is working through. The player that will be rendering yyy will sign-on to remote service zzz, requesting track yyy. The service will return yyy data to the rendering player which will also notify the controller of yyy’s progress. If the rendering player is actually part of a stereo pair, the left player will be managing the connection with zzz and splitting off the right channel, sending it to the right channel player over the network. If you are asking SONOS to play yyy on a “Group” of players, that left channel will become the Group “Coordinator”, sending yyy traffic to the other players in the Group. Any left player in the Group, will split off the right channel for its stereo pal. Status data from each player in the Group will be sent back to the controller.

As you can see, this simple request to play yyy can generate a blizzard of local network traffic. If a router or other component on the network throttles a SONOS Group Coordinator too tightly, SONOS cannot function. It is not usually necessary to impose network traffic throttles on typical home networks. For large office networks, bars, schools, and such, traffic limits might be imposed, but this is a very different type of network that is managed by specialized professionals.

There may be legitimate reasons to limit traffic to external services. For example, if you have a limited monthly data cap, constantly playing music or videos from external services could run through your cap very quickly. 

Hi.  You stopped one screen short of where I asked you to go.  The SonosNet Channel is not relevant here.  Please go to System, Network, Manage Networks (actually tap on “Manage Networks”).  I’ll post the screenshot from my system in a moment.   Does your equivalent screen have your current network name listed?  I am just trying to understand how your network and Sonos are set up.  It is hard to help without that basic picture.

 

Badge

Hello John and @buzz: Thank you both. John, I can’t get to a screen like that. I don’t show the name of any active wireless network, just SonosNet. I can get to a “Network” screen - that lists three things “Wireless Setup” “Networks” and “Sonos Net Channel - Channel 6.” If I click the first of these, it gives me a new screen “Set up Sonos on your WiFi.” However, I cannot do that, since it refuses my network password. If I instead click on the second of those three things, “Networks,” it just gives a screen that says “In use” and nothing more.

Thanks to these explorations and John’s comments, I now think I see why disabling wireless on device A cuts off device B from the system. It’s two things acting together: (1) I have no WiFi at all working on Sonos now. Sonos is operating (very well, by the way) via the ethernet cable to A and the SonosNet connecting A and B. Neither A nor B get Wifi, because I can’t get Sonos to take my WiFi password. (2) disabling wireless on A ALSO disables SonosNet on A. John explained that, something I had missed completely. So, given point (1), with wireless on A disabled, and no WiFi at all, B has no connection to Sonos.

So that’s where I feel the diagnostic picture is. In this situation, given point (2), I no longer want to disable A’s wireless. I’d prefer to have the Sonos devices communicate on SonosNet, rather than have device B use the home WiFi system to link up. Seems to me a lot is already going on with home WiFi (lots of family members with their devices), and SonosNet exists for a reason, to provide a clean connection.

Let’s go back for a moment to the underlying problem I want to solve. Where I live, I get very limited internet speed to my home. The result is when other family members have their devices on I get dropouts playing Sonos. My ISP technician explained that the router partitions the incoming bandwidth from the ISP equally across all WiFi devices it detects. It detects both Sonos devices (I can see that on the ISP diagnostic screen), in addition to the ethernet link to device A, meaning it uselessly parcels off 2 chunks of bandwidth, to A and B, even though no data ever flows there (point (1) above). Disabling all radio from A, thereby knocking out SonosNet, does not sound like a reasonable solution to this problem. Better would be if I could teach the router to ignore Sonos A and B on WiFi, and just keep the ethernet connection.

 

 

 

 

It sounds like you have understood the position very well, and also reached the right conclusion about what NOT to do!

This stuff from the ISP about bandwidth being allocated sounds a bit implausible to me, but i don’t know enough to really challenge it.

The reason you didn’t have a “Manage Networks” screen is because you don’t have any WiFi networks added to Sonos - which was why you were seeing the behaviour you were seeing, and which you now understand.

Now we know where we are, I would now (after all) like to know which wireless channel your router is using.  If it is set to anything other than 1 or 11, please set it to 1 or 11.  Your problem may be caused more by wireless interference than “bandwidth allocation”.

Proteus,

When using SonosNet the only part of the “blizzard” that I described above that’s important is the traffic that ends up going out to the WAN (Wide Area Network -- the Internet). There will be minimal WiFi traffic to the SONOS controllers only when they are awake. Traffic between SONOS players will be handled by SonosNet.

Badge

I had the ISP reconfigure the WiFi so it uses only channel 1 and channel 11, never channel 6. The ISP technician thought WiFi interference may be the source of my troubles, and this should fix that. They also asked me whether I wanted to configure the ethernet connection to Sonos as 2.4GHz or 5.0GHz. I said 2.4GHz, because reading the Sonos documentation I understood that’s what Sonos supports. However, if you advise me to change to 5.0, this would be easy to do.

 

I guess the thing to do now is try it out and see if the problem is resolved. Buzz, I do follow you about the blizzard being on SonosNet. I hope I’ve now got it set up so there’s no interference with that blizzard.

I will let you know, either way, how this works out. Many thanks for all your support.

 

 

Badge

Well, I don’t have happy results to report. I am still getting occasional drop-outs. Sometimes there’s silence for a second or so and then it picks up where it was. Sometimes something strange happens - it goes silent, and then skips one track forward (always forward, always to the next track). What might be causing this behavior with my current configuration? How to diagnose and cure?

When playing from an external service the typical response to a large communication issue is “I give up on this track” and the next track in the play sequence will be attempted. A short communication issue will result in a mute. It’s a judgement call by the player as to the severity of the communication issue. If it seems like a brief issue, the player will mute. At times the player will bungle through, assuming each of a long string of issues is minor, resulting in a cascade of “brief” mutes that is effectively a perpetual mute for the listener.

Submitting diagnostics and working through SONOS support is your best plan, We don’t have access to the diagnostic data. Local and remote issues will leave characteristic tracks in the diagnostics. Submit within 10 minutes of an issue because fine diagnostic data will eventually start to scroll out of view.

Badge

This makes perfect sense, thank you. I just encountered another moderately long drop-out and submitted diagnostics right away. In case someone on this thread is able to read the diagnostic, the confirmation number is 1611198388. I’ll try to connect to Sonos support with this.

Unfortunately, those of us outside Sonos don’t have the ability to read the diagnostic data, probably due to an amount of PID in them. 

I had the ISP reconfigure the WiFi so it uses only channel 1 and channel 11, never channel 6. The ISP technician thought WiFi interference may be the source of my troubles, and this should fix that. They also asked me whether I wanted to configure the ethernet connection to Sonos as 2.4GHz or 5.0GHz.

This is completely meaningless and increases my suspicion that you are being fed a lot of nonsense by the ISP.  Ethernet cannot be 2.4GHz or 5GHz.  It isn’t wireless, it’s wired!!