Question

New Router with New Wifi name; can't get past the button press

  • 27 November 2019
  • 2 replies
  • 63 views

We got a new router today and the name of the wifi network changed. I tried to update my Sonos Amp with the new name but it couldn’t seem to find it. I saw that you needed to update the app to the latest version but couldn’t see that the app needed an update. So I deleted it and re-downloaded it from the cloud.

I launched the app and have two choices: set up a new Sonos system or Connect to an existing system. I hav tried both and neither work.

I think I can’t connect to the exisiting because it is on a different network (the old name)

When I try to set it up as new, I can’t get pass the button press. It finds the Amp but the next screen says to press the button on the bakc. I have done this multiple times and get a screen after about 45 seconds that says “Button press not detected.”

What should I do? Should I do a factory reset? How do I do that?

Thsi was so easy to set up initially. Can’t understand why this is so screwed up. Should be easier than this.


2 replies

Userlevel 7
Badge +21

You likely have your router set up somehow that is incompatible with Sonos. As a quick fix you could wire one Sonos to your Ethernet and get it working.

Check the router to make sure it is using 2.4 GHz and B/G mode for the WiFi.

If you haven’t changed the SSID and password on your Sonos set the new router to use them too. You can change once things work.

Try a simple SSID and Password like: DEADBEEF and password as a starting point, if they work then get fancy. Don’t leave the simple ones up long!

 

Thsi was so easy to set up initially. Can’t understand why this is so screwed up. Should be easier than this.

It is easier than this.  If all else fails, read the instructions.  

https://support.sonos.com/s/article/1061?language=en_US

Reply