Answered

Sonos and Alexa

  • 17 February 2023
  • 7 replies
  • 106 views

Pretty sure that this isn’t a fault with my Sonos kit, but hoping others may have had a similar issue and know how to fix it. 
 

I have two Echo Dots. One in the lounge and one in my bedroom. The lounge Dot works in conjunction with my Sonos PlayBase, which is paired with 2 Sonos One SLs. In my lounge, if I ask Alexa to play BBC Radio 2, she duly obliges and the music is played via the Sonos speakers. If I do the same thing in my bedroom, where the Dot works with a single Sonos One SL, Alexa plays Radio 2, but from the Dot speaker. What’s more, if I specifically ask her to play it on the bedroom speaker, she refuses. 
 

I’ve heard that this may be a licensing issue, but that doesn’t explain why it works as desired in the lounge.

 

I’ve double checked all the settings, and they are the same on both Dots and all the speakers. 

 

Moderator edit: Added that “Ones” are in fact “One SLs”

icon

Best answer by Joncuthbert 17 February 2023, 16:06

View original

7 replies

The Alexa group looks fine to me - 👍

If you click change in the ‘speaker’ section of the group next to ‘bedroom’ and scroll past the devices in the list, to the section that is entitled ‘Playback Options” just ensure that is set to ‘Always’ and not ‘Only when you say the group name’.
 

Also it’s often worthwhile having a different group name, rather than having it set to the same name as the speaker - I have ‘Bedroom’ speaker, but it’s in the ‘Main Bedroom’ Alexa group… maybe see if that makes a difference. 

I’ve just managed to work it out. There is a ‘Playback Options’ section when I select the Sonos One. Options are ‘only when I say the group name’ and ‘always’ I’ve changed this to ‘always’ and it now works.

 

Would never have found this setting without the input from this thread though. Thank you

Does this happen only for Radio 2?  Are you able to play Radio 2 through the Sonos app?

The only advice I could give is to temporarily disable the Sonos skill via the Alexa app, and then re-enable it.  Sometimes these fixes these odd issues, but you will also need to recreate your Alexa groups.

Hi Danny. It does the same for all BBC channels. I don’t often listen to other stations, but having just tried a few, they all seem to work. I can play Radio 2 via the Sonos app. Would've thought if it was the skill, it wouldn’t work downstairs though? Will try anyway

 

Alternatively, you could try to remove the speaker from your bedroom group then re-adding it.  It sounds like one of those issues where it’s just not working as designed and a reboot of sorts is the best solution.

Does this happen only for Radio 2?  Are you able to play Radio 2 through the Sonos app?

The only advice I could give is to temporarily disable the Sonos skill via the Alexa app, and then re-enable it.  Sometimes these fixes these odd issues, but you will also need to recreate your Alexa groups.

Hi Danny. It does the same for all BBC channels. I don’t often listen to other stations, but having just tried a few, they all seem to work. I can play Radio 2 via the Sonos app. Would've thought if it was the skill, it wouldn’t work downstairs though? Will try anyway

Hi Ken

 

Thank you for taking the time to help me out. I ‘think’ mine is set up correctly. See image.

Also, and I should’ve mentioned this in my original post, this behaviour only occurs with certain radio stations.

 

For example, if I say ‘Alexa, play Fleetwood Mac in the bedroom. Fleetwood Mac plays via the Sonos.

 

@Joncuthbert,
This is likely going to be an incorrect configuration of your Alexa ‘enabled’ groups - ensure the bedroom Dot is in the same Amazon Alexa group as the ONE-SL and that it is controlling the group.. see screenshot (just as an example only). The echo dot needs to be in the first ‘controlling’ section and the One-SL set in the speaker section (3rd section of the group) and for ducking purposes also add it to the 2nd section of the group.

Does this happen only for Radio 2?  Are you able to play Radio 2 through the Sonos app?

The only advice I could give is to temporarily disable the Sonos skill via the Alexa app, and then re-enable it.  Sometimes these fixes these odd issues, but you will also need to recreate your Alexa groups.

Reply