Sonos over large area

  • 2 December 2022
  • 4 replies

We use Sonos to deliver music in a course that we teach.  The course involves us visiting small hospitals and I have to get Sonos working, sometimes, over larger distances - and I am looking for advice around this rather than continuing with the repeated pain of my trial and error!

We set up a mesh wifi network - the router is plugged into a working ethernet socket and this gives us internet access for some other purposes that we have.

I usually plug a Play1 or a Boost into the router and then the other 6 Sonos speakers are placed in rooms - that can be far apart.

I do not plug the Play1 or Boost into the hospital ethernet directly because I think they tend to block it (hospitals don’t usually want folks playing music day in , day out via their networks)

The problem i have is that the distant speakers are sometimes too far - I can usually ‘see’ them in the app but playing music fails because of network speed.

So….options?  I have tried using a couple of other Boosts in the hope that they act like wireless repeaters (not ethernet connection).  I am not sure that this works - I guess it might depend on whether Sonos is using its own network, or the mesh system that we set up.

I have thought of plugging a boost into a speaker that is within range - hoping that the Boost will push the signal further than the speaker.


I also wonder if if Sonos is using its’ own network, and that if my mesh network is strong...then perhaps telling sonos to use the mesh might work better...but I am not sure how to ensure that it does this.

Sorry for the long question!

I should add that we have been shipping 2 Sonos systems around, each about 12 times a year,  setting them up, packing and re-shipping them etc since 2010….and not one piece of them has failed - solid product!

Thanks all for any advice.






Best answer by Corry P 2 December 2022, 17:39

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

Userlevel 7
Badge +18

Hi @jelcoward 

Thanks for your post!

First, using a router is a good idea!

When you have 1 or more Sonos devices connected to ethernet, they will create their own mesh network and prefer that over any normal WiFi they might know the credentials for, even if the signal is better (to a point). Each unit connecting to SonosNet will rebroadcast it. The best way to determine how a particular unit is connecting is via Settings » System » About my system. You’ll see that each unit has either WM:0, WM:1 or WM:2. WM:0 means the device is either connected to ethernet, or is using the SonosNet mesh. WM:1 means it is connected to a WiFi broadcast, and WM:2 means it is connecting directly to a Home Theatre unit as either a Sub or a Surround speaker.

A wireless Boost can bridge a gap between a speaker connected to SonosNet and one trying to - if a speaker is on WM:1 when SonosNet is present, it likely can’t receive SonosNet well enough and a wireless (or wired, for that matter) Boost located in the right place can help. Note that a speaker will prefer a weaker signal over one wireless connection than a better signal which requires two wireless hops to get back to the ethernet connection.

Plugging a Boost into a speaker won’t help - more likely the opposite, as said speaker is already transmitting what the Boost would then transmit but interfere, though I suppose if the cable were long enough and the Boost far away enough it would help.

If you do use SonosNet, it is very important to not have the wired Sonos unit and the router closer than 1m - if they are, they will interfere with each other’s broadcasts.

When grouping speakers together for playback, the first one selected can be an important choice. When Sonos is on WiFi, use the closest speaker to the router for the best results. When on SonosNet, use a speaker that has an ethernet connection, or the one that’s closest to the wired Boost if only the Boost is wired.

Finally, try to make sure that the WiFi and SonosNet do not use overlapping WiFi channels. SonosNet can only be on 1, 6 or 11 (which are the only non-overlapping channels), so make sure your router isn’t a) on the same channel as SonosNet, or worse, overlapping and b) isn’t channel hopping depending on what it thinks is the best at any given moment (Auto). All the channels in between 1, 6 and 11 will overlap with the closest two of these listed. SonosNet channel can be changed at Settings » System » Network » SonosNet Channel.

Combining these tips should help, but your use case is very unusual for Sonos. I hope they do.

Thanks for the detailed reply Corry!! That is great!  You have confirmed some of what I was thinking and given me some more info to feed into my thought processes - especially the info re seeing what each speaker is using.

If I find the optimal way I will report back.


Go to http://[IP address of a player]:1400/support/review and check the Network Matrix at the bottom. Red cells are drawing your attention to potential problems.

Note that this is a static view. You’ll need to refresh the page to check dynamic conditions. It’s unfortunate, but the newest players do not submit data for the Network Matrix. Your older players and the BOOST will submit data.

The Network Matrix could be very helpful for you because you can check connectivity immediately after setup. Unfortunately, conditions can change, especially in a hospital if some wireless polluting device comes online. Note that humans are mostly bags of water and water absorbs the RF spectrum used by SONOS. This means that you you can check an empty room and it works fine, but once it fills with water bags, things go downhill. Raising the players and BOOST(s) above the crowd can help.

Sorry to be slow with my thanks Buzz!  I will take a look at this when we are teaching the next course and have Sonos set up.

Cheers :)