Sonos Amps not registering - Crashing app


While trying to setup a new Sonos Amp in the new app, it won't register.  Then, you go to settings to manually register, and the app crashes….every time.


App is current version and iphone running on latest IOS.


This new app is absolutely horrible.  You made unnecessary changes to an app that was already easy to use and show customers how to use.  Completely unnecessary to overhaul this like they did.  If you want to give it a cosmetic refresh - fine, but this is just horrible.

4 replies

Userlevel 1
Badge +2

Same problem exactly. Latest iOS. Latest Sonos app. Tried on both iPad and iPhone, no difference. 

Existing Sonos system so I know it works.

Amp has been in my system before so I know it works. 

Steps leading to crash:




Userlevel 1
Badge +2

Not an easy or great fix, but this worked for me.

Go into the controller app and choose to transfer ownership of the system (settings/manage/transfer system ownership), putting in your account as both old and new owners. 


Will give that a shot and report back.  Thanks for the help!


Guys, I’ve got the same problem. My Sonos Amp isn.t registering because the app keeps on crashing. I trief it on IOS and Android. Transferring ownership didn't work. App keeps crashing.