Help with Sonos/Unifi (have checked other unifi articles)

Userlevel 1

Hi community,


I’m after some help please with Sonos/unifi. I’ve tried to follow the recommended configs and other articles, but think I have a “perfect storm” of things and I’m struggling to resolve. [NB, I’m a home enthusiast/tinkerer, and not an experienced networker, so struggling to work out next steps]


Maybe there’s someone with experience based in Sydney, Au who can come and help diagnose on a paid engagement (Pls DM me if possible?)


I have a “perfect storm” of three things combining and I simply can’t get Sonos to work anymore.


Summary of Setup:


  • Sonos: 13 devices (Room 1: Arc/Sub/Amp; Room 2: Arc/Sub/Amp; Room 3: Amp; Room 4: Amp; Room 5: Era100; Room 6: Five; Outdoors 1: Amp; Outdoors 2: Amp; + Move)
  • Unifi network config as follows:
  • Fibre Modem -> UDM Pro SE -> 24 Pro switch (via SFP+; switch set to STP @ 4096) -> 48 port switch (via SFP+; set to STP 8192) -> 7 x AP's via CAT6 all over the house)
  • All device firmware up to date (Network 8.1.127)


Up until recently, the Sonos had worked "ok" but had random dropouts (noticed mainly when entertaining with system running for hours at a time).


Sonos was originally setup with 1 x ARC hardwired via CAT into the 48 port switch, which created Sonosnet to most of the other devices (except the Era100, Five, and one of the AMP's which kept dropping off due to it's location being a long way from everything else).


The three recent changes are:


  1. Updated Unifi settings: To try and resolve the random dropouts, I tried applying network updates as per (article here)
  2. I thought hard wiring all devices I could would be better…. Made things much worse. Broadcast storms, etc. So went back to none wired, which required some factory resets.
  3. App upgraded to latest Sonos app during 2 above, and everything then went to shi!te!


The issues now:

  • App won’t connect to system 9/10 times (see image). It's like the Sonos system doesn't exist on the network.
  • Examples of errors here
  • App connects 1/10.... And when it does, it seems to work ok. BUT: If I try and add devices (have factory reset a number of devices) when trying to add them the app says Wi-Fi password is wrong, then app stops seeing network/system completely.
  • Next time I open app - doesn't connect again.
  • Can’t connect to ANY Sonos device via Spotify (it’s like the Sonos system just doesn’t exist on the network)


Fortunately the Arc bars still work with the TVs so we have sound.


I’ve spoken to Sonos support who just said “we are having a lot of customers calling about the latest app. The solution is to wait for an app upgrade, likely a few days”.


Other actions:

  • Have rechecked all the recommended Unifi settings in this article and all seems correct.
  • Have restarted Unifi and all switches multiple times.
  • Have "Reset Sonos App" multiple times.
  • Sonos APP on iOS updated to 80.00.08 a few days ago - has made no difference.


Things to check:

  • Could I have somehow setup multiple Sonos systems on the one Wifi in the one account and this is confusing things?
  • Could the factory reset have confused things? (i've tried every device now)


I genuinely don't know what to do next except find someone with more experience to try and diagnose, or hope that a Sonos App update will resolve the issue.


Can anyone spare a little time to help troubleshoot?


Very much appreciated!


Sydney, Australia.

13 replies

Userlevel 1


I seem to have resolved this with help from Sonos support, using a suite of settings some of which are different to that outlined in the articles referenced above.

Settings as follows:


  • Multicast Enhancement Off (unticked)
  • Multicast and Broadcast control OFF (unticked)
  • Proxy ARP Off (unticked)
  • Client Device Isolation Off (unticked)

Randy at Sonos support was really helpful this time, and was able to lookup specific settings related to the Unifi UDM settings.

Will update if I continue to have further issues.


HI Rexi

Sounds like my problem with UNIFI and SONOS.

Do you mind sharing more settings to check what I can change?


The hardwired speaker works but all the other causing issues like can't connect, random dropout, volume sluggish, grouping and more.



Userlevel 1

Hi Marco, Screenshots of all settings below.


However, important to note, I’ve also moved to NO WIRED DEVICES at all, and it’s working SO much better than it ever has. New app works well, grouped devices ok etc.


There’s definitely an issue with a combination of wired/wifi Sonos devices on Unifi.


If you can, my experience is go wifi only.


Cheers - Scott


Wifi Settings:



Global Network settings:


LAN Settings:



Thanks so much, will have look later.

The new app misses some functionality re setup can you switch from wired to wireless at that stage?

Userlevel 1

Hi Marco - I’m not sure what you mean. I’ve moved to completely Wi-Fi, so have no more wired devices and it’s working the best it’s ever been. I did factory reset the devices that were wired, and re-added them to the system using the new app. New app worked fine.


Hi Rexi

I checked all my setting and there were same as yours besides having DHCP Snooping activated on your side. Not sure if that will make any difference.

Miracle, it works better today without any changes 🤔.

Currently I have one zone wired, I will check to make to move to none wired if it make a difference.

Thanks for your help



Userlevel 1

Good luck!


How did u change from wired to wireless? as the instructions below dont work atm.

Userlevel 1

Hi @marco.schwald 

Here are the steps I took to successfully go to “all on wifi”…


  1. Pull the power out of all your Sonos devices.
  2. Pull the Network cable out of the currently wired device.
  3. Logout of the app, then close the app
  4. Restart your router.


When router is restarted:

  1. Turn on one of your Sonos devices that was on wifi;
  2. Check the app and see if you can see this device in the app.
  3. If you can, then proceed to turn on each of your other Sonos devices one by one…. hopefully they join the network ok.
  4. If not, you might need to factory reset the device and re-add it to the system.


I did factory reset a couple of devices.


I’ve currently got 3 different audio sources running different audio in different parts of the house with no issues, and no (noticeable) dropouts. I can also group/any any speakers quickly. This is a first, so all seems working well for me now.


Sonos phone support has been helpful, despite a 30+ minute waiting time.


Good luck!

Userlevel 7
Badge +22

If you already have the WiFi password in the system just unplug the wired Sonos and they will switch.

Userlevel 1

Give that a go first for sure! For some reason didn’t work for me (but probably an issue with the combination of incorrect Unifi settings and upgrade to new app that all happened around the same time)

Hi Rexi

I am having similar issues. Good to hear yours is working now, it gives me confidence to persevere  

Did you create a specific wifi network for only Sonos devices? If so, is your phone connecting to that same network?


Userlevel 7
Badge +22

Most Sonos and Sonos Controllers need to be on the same network.

The web based controller can work from anywhere but is a bit limited.