Answered

Arc drops randomly from LG oled TV

  • 15 March 2024
  • 4 replies
  • 182 views

Badge

My setup:

  • LG 65” OLED (OLED65C3AUA.AUS)
  • Sonos Arc SL 
  • No other devices plugged in to TV 
  • HDMI plugged in to port 2 in TV (e-arc/arc port) 
  • Audio output: “HDMI Arc” with so sound options available (all greyed out on TV)

My problem: 

Sound will stop working after 20-30 minutes. Absoutely no input change, volume change, or app change. Sound goes from working perfectly to being silent. Very frustrating. I unplug/re-plug the power and the HDMI several times and then it works again. 

What I’ve tried: 

I bought a new, high-quality HDMI cable and the problem persists, so I am back to the Sonos-included cable. When the sound goes off, the Arc is still on, and the sound still works on the Arc (when I physcially presst he volume buttons in makes the thumping sound) and the led turns on. I have updated the firmware on both the TV and the Sonos, and I have checked the plug connections a million times. 

Anyways, this is a brand new tv and this is extremely frustrating. Please help. 

Thanks

icon

Best answer by GuitarSuperstar 15 March 2024, 23:36

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

Badge

Reporting back here that changing the LG Olded’s digital sound output from “auto” to “passthrough” has fixed the problem. Hopefully this helps people in the future. Thank you to the GuitarSuperstar. 

Userlevel 7

Make sure the TV is set to these settings:

Digital Sound Output: Pass Through

eARC Support: On

 

Then do this:

Disconnect everything from the TV and unplug the Arc and TV from power for a couple of minutes. Plug everything back in but keep everything disconnected. Make sure Simplink is enabled in the TV settings. Run TV Setup in the Sonos app and follow the app instructions. When the app instructs you, connect the Arc to the TV’s HDMI ARC/eARC port using the Sonos-supplied HDMI cable.

Badge

Thank you very much. 

The digital sound output was set to “auto” and have now changed to “pass through” per your instructions, and so far so good. I’m hoping that does it!

The “HDMI Input Audio Format: Bitstream” remains greyed out for me. 
 

Hoping this works! If not I will try to figure out bitstream and follow the rest of your instructions.

 

Userlevel 7

Ignore the HDMI Input Audio Format setting. It only applies if you have other media devices connected to the TV via HDMI.