only connects when one speaker on wired network

  • 23 December 2022
  • 2 replies

I have 4 play 3s and a play one.  We recent upgraded our wireless system. Now the sonos only works when one speaker is on the wired network.  If I try to reconnect to wireless I get an error from the app.



Best answer by Ken_Griffiths 23 December 2022, 19:52

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

@Jim Edwards,
After wiring one speaker to the new router, first power-cycle all the ‘other’ Sonos devices. Do not factory reset any of your Sonos products. Ensure the mobile controller is connected to the new router’s WiFi network (2.4Ghz band, might be the best option). Also ensure…

  • Airtime Fairness is not enabled on the router.
  • QoS is not enabled on the router.
  • The wired Sonos device is placed at least 1 metre away from the router to prevent interference.
  • That the wired and wireless network segments on the subnet are not isolated in the router settings.
  • That the WiFi is 802.11b/g/n compatible and perhaps set the security mode to WPA2 AES personal.

Hope those suggestions first help you to get your system back up and running. Then when all devices are present and showing in the Sonos App, you then need to add the new routers WiFi network credentials to your Sonos system, just goto Settings > System > Network > Wireless Setup and follow the onscreen instructions to connect all devices in the App to the new Wi-Fi network. You can then uncable the wired Sonos product.

What kind of error?

Without much information, my guess is twofold. First, the network being provided by your new router doesn’t match the network requirements for the type of antenna in the Sonos. See the Sonos Network Requirements FAQ.

The other possibility is that you’ve not yet updated the network information with the new SSID and password in the Sonos controller, and Sonos is still trying to connect to your old network. This would be in Settings>System>Network>Manage Networks.