Cutting in and out using Samsung TV

  • 15 May 2017
  • 8 replies

I have two identical Samsung 4k TVs each connected to a separate Playbar and with surround speakers and each with an optical connection. Both of them suffer from the same problem that intermittently they will cut out for 5-8 seconds and then the sound comes back. This does not happen when streaming music on Spotify through wi-fi. I have tried resetting everything and have checked all connections. The Sonos and TV software is up to date including Router firmware (Asus RT-AC3200). Any ideas on how to fix this would be appreciated!

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

I'd highly recommend that you submit a system diagnostic after getting one of those issues, and letting the folks at Sonos have a gander at the data involved. You've already done much of the troubleshooting that I'd recommend.

The router actually wouldn't have an effect on this, since the data is streaming directly from the TV to the Playbar through the optical port. But you've checked the firmware on the TVs, which is good. And since Spotify is streaming properly, the issue isn't with the Sonos speakers themselves. My suspicion is something odd in the data stream from the TV. Oh, you should, just for completeness, double check that the optical connector is seated properly in both the speakers and the TVs, but I doubt that it is an issue.

Can you reproduce the issue? If that drop happens at a particular place in a program, if the program is recorded, can you back up the recording and play it again and cause the drop out to happen in the same place? That might be useful to know, when you end up getting someone from Sonos to look at the issue. What I'm thinking on that line is that perhaps the TV Audio settings output isn't set to "fixed", and the variability of the sound gets too low for the speaker to pick up the data. It's an outside shot, but something worth ruling out. If it doesn't happen in the same place in the program if you replay it, then it's ruled out 🙂
Thanks for your comprehensive reply. I will submit diagnostics. I had checked both optical cables are seated correctly and have tried replaying the same section of movie when sound dropped but it doesn't replicate. It is most bizarre!
Yea, sounded like you were pretty much on top of everything, but I like to respond as if the OP is not the only person who will read it, and hopefully help others who aren't as clued in as you are :)

Be sure to post those numbers of the diagnostic(s) here. I suspect that they get quite a few and without someone pointing to which one and letting them know what the issue is, they probably don't look at them (depending on how busy they are).
First diagnostics #7400332
Userlevel 4
Badge +3
Hi daphnescombine, welcome to the community. Your diagnostic shows the PLAYBARs are being repeatedly de-authenticated from the wireless network of the Asus router. This is happening because the router is not updating them with new encryption keys in a timely manner. There's a few ways to get around this. The easiest would be to simply connect any of your Sonos devices into the router with Ethernet, if any happen to live nearby to it anyway. This will mean that all your other Sonos players leave the Asus WiFi and join a network broadcast by the wired player instead.

Another option you can possibly try is adjusting the beacon frame interval settings. You can do this in the router's configuration page. Go to Advanced Settings > Wireless > Professional tab > change the Beacon Interval to 0. If the router will not allow this value to be 0 (some don't), just leave it as it was before and in that case you'll need to wire a player in.

If you're using custom firmware on the router, please revert to the official Asus one. We do see problems quite a lot with custom builds.
Unfortunately the router is not near any of the speakers. The Beacon Interval can only be between 20 and 1000. Default is 100. I'm not using any custom firmware on the router. Any other suggestions? Thanks.
Userlevel 4
Badge +3
If you are on Asus' own firmware, then that's usually quite good at this. Do double check it's definitely up to date on their site. It might also just be a temporary bug. Have you tried restarting the router recently?
Yes i have. I also remembered that i have a TP Link Powerline Adapter so have connected that to the router and one of the surround speakers. Will see how this fares and will report back. Thanks.