Answered

Unable to save Roam to group


I have two Sonos Plays and a Roam. I can group the Sonos plays  together, but not the Roam. All are visible in my system and selectable in the Grouping option, but when I try to save the group (either with all devices together or just the Roam), I receive the following error: “Unable to save group. Try again later”.

 

I have tried later, much later, and much much later to no avail.

icon

Best answer by MProdor 26 July 2023, 15:03

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

16 replies

Hi All, thanks for your help on this. I confirmed I had the correct App (S2 - Gold icon), that it was up to date, and that my Roam was connected to the correct WiFi.

 

This morning I took the nuclear option and performed a factory reset on the Roam and readded it to my system.  That did it! I can now add it to groups and select it as a separate device, with out adding it to a group.

 

Thank you all for your help. Sometimes everyone just needs a good jolt of factory rest to get things aligned. 

Userlevel 7
Badge +18

Airgetian - understood, but I do not have any othr alternative. When Ever I try to add the Roam, it requires I add it as a group. Here are the steps I use:

 

  1. Select music/play list
  2. Click the square/Arrow on the bottom of the app, beside the volume
  3. Click the “+”
  4. Chose Roma under Available
  5. Enter a Group Name
  6. Click Save

Receive “Unable to Save Group., Please try again later.” message

Rather than clicking the “+”, which is to create a permanent group, just click to select the room(s) you want to include in your temporary group. Then click “Done”. 

This did not solve the issue

Userlevel 7

Try deleting and reinstalling the Sonos app, and make sure the Roam is powered on when you try to save the group.

Hey GuitarSuperstar, thanks for the help. Still no luck after installing and reinstalling the App. It seems that  I cannot creat a group wth the Roam in it. I get the “cannot save” message every time.

 

I can create groups with the other Sonos products, without seeing the error. Including the Roam seems to trigger the error.

Userlevel 7
Badge +18

It might be that the Roam (and the same for Move) can’t be permanently grouped because they are portable devices. What should the app do when you remove the Roam to play elsewhere, then try to play to the group and there’s a speaker “missing”? 

OK, that makes sense, but I should be able to add the roam to my system when it is on. I am not given an option to add it, when I am playing music with out adding it to a group.

 

Currently, the only way tolay music is though Bluetooth and Spotify. This prevents me from using all the devices at the same time.

There is a difference between grouping for playback, and saving a permanent group, isn’t there? I would think the first is easy to do, I’ve never tried to place a Roam in a ‘permanent’ grouping for exactly the reasons @nik9669a suggests…it’s a transient device. 

Airgetian - understood, but I do not have any othr alternative. When Ever I try to add the Roam, it requires I add it as a group. Here are the steps I use:

 

  1. Select music/play list
  2. Click the square/Arrow on the bottom of the app, beside the volume
  3. Click the “+”
  4. Chose Roma under Available
  5. Enter a Group Name
  6. Click Save

Receive “Unable to Save Group., Please try again later.” message

@MProdor,
I have just quickly setup a 3 player Sonos system to test this with…

  • Sonos One called ‘Foyer’
  • Roam called ‘MotoRoam’
  • Roam SL called ‘Voiceless’

… and have no issues creating a group called ‘Test Group’ in the latest iOS S2 controller App.

See animation I created a few moments ago…

 

Perhaps try again by going to ‘Settings/System/Groups’ in the S2 App and create the group there as per the animation above. 

Sorry the animation is limited in its quality, but I was limited by a 5mb upload limit on the forum here.

@MProdor,

If you do have an existing ‘group’ that’s been created in the Sonos App already, then I would first delete that group ..and then start again with a brand new group.

Thanks to everyone for trying to help on this.

 

@nik9669a  - see the attached picture, my only options when adding another “room” is to use the “+” sign. The Roam is grayed out, until I click the “+”, which takes me to the group creation.

 

 

@Ken_Griffiths  - I can create any group in the App, except when I try to include the Roam. I removed all groups, recreated my Groups, then tried to add Roam I get the attached error message:

 

Is it possible I’m using the wrong controller - My App just says Sonos and not Sonos S2

Userlevel 7
Badge +18

Roam requires S2. 

That’s probably why it’s greyed out in the screen shot above.

Frankly, I’m surprised in your first post that you say “All are visible in my system and selectable”. I would have expected it not to install on S1, or else never to have been selectable in the app. 

 

Anyway, that seems to identify the root cause and solution to your issue. 
 

BTW, in the screenshot above, Sonos Roam is greyed out meaning it’s not accessible. Once you upgrade you’ll get a similar page, but the Roam should not be in grey. If you click the selector circle to the left of the roomname (“Sonos Roam”, in your screenshot above) you can group it with your Bookshelf and/or Office. 

@MProdor,

My S2 App (gold icon) just says Sonos too - my S1 App (black icon) says S1 Sonos, so I think you probably have the correct S2 App here. Can you confirm the icon to launch the App is gold coloured and not black? - If so, something is not right - have you checked for any Sonos updates to see if there are any firmware updates that need to be installed on the Roam?… ‘Settings/System/System Updates’

Can you confirm you see all three of your speakers in ‘Settings/System/About My System’ in your Sonos App - can you also just ensure that your Roam is connected to the same WiFi access point and WiFi band as your mobile controller device.

 

 

Userlevel 7

Try rebooting the Roam, your router and your phone.