Sonos Move no longer visible cannot connect to APP

  • 15 December 2023
  • 6 replies

I have a Sonos move that is now out of warranty. Without any warning last month November 2024 i lost connectivity of move and could not add to my APP S2. I have attempted multiply fixes with Sonos Support to no avail, who now advise me that as machine is not in warranty all they can offer is a replacement voucher, this is my 5th Sonos product that i have purchased without any issues.

So disappointed with the response by Sonos and am now seriously considering purchasing a different speaker, £300.00 for a machine that lasted just over 2 years and then to have Sonos accept no responsibility for a flaw that if researched is clearly there doing. So disappointed with the product- imagine selling something that has compatibility issues with specific wifi settings\channels- i have had no changes with my network recently and the Move has not been damaged in any way, really poor by Sonos.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Factory reset seemed to work in the end its not enough to remove from charger and turn on and off, there was a third steep to complete that I had missed which I cant remember and is not mentioned in all the tutorials. 🙈😂.

Did you resolve this problem. I have the same.

Make sure the WiFi is 802.11b/g/n backward compatible with security mode WPA2 AES for the setup and that the mobile controller meets the requirements shown in the link below and has no security software getting in the way, such as VPN client/firewall etc.

To add the device to an existing setup, ensure it has been reset and has a flashing green status LED, indicating it’s ready to be setup on the system.

Did you resolve this problem. I have the same.

The Battery does not need replaced and i have tried the factory reset multiple times- i keep getting an error saying mobile device can not add Move- i have tried multiple devices as well. Very disappointed with Sonos presently and am seriously considering moving onto a different product. It doesn't seem fit for all WIFI systems

Userlevel 7
Badge +21

I've had a Move 1 go AWOL. Try the following, it’s worked for me.


Remove the Move 1 from the Charging base, this is important. 

Long press the Power Button for at least 10 seconds.


Leave for 10mins still off the base.

Turn on the Move 1 with the rear power button, 2 second power button press.

It may turn on an now be able to connect to your system. 

If still not working then try a Factory reset on the Move ONLY.


Userlevel 7

Does the battery need to be replaced?