Problem adding Sonos Roam to system even after several factory resets still does not show up

  • 23 June 2022
  • 1 reply

I currently have updated to the latest Sonos App and run the update for the Sonos Roam.

I am following the factory steps to add to the system and currently have a Sonos Roam in the system but for whatever reason I am able to add the Sonos Roam.  It tells me to power down the roam and restart.  Upon restart the Sonos Roam shows as offline in the app even after several restarts.


I tried factory reset and to re-add a couple times and still no progress.


Best answer by Ken_Griffiths 23 June 2022, 03:29

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply


I will first just assume you have added the (factory reset) Roam successfully via the ‘Add Product’ feature in the S2 Sonos App ‘Settings/System’.

Power off the Roam fully with a 5+ seconds press on its rear power button until you hear the shutdown tones.

Fully close the Sonos App (slide off screen) and reboot the controller device whilst standing near to the main router.

Whilst near your router (within 6 feet or so) then power on the Roam and see if it now appears in the App when it’s opened.

If not, then check your router and ensure QoS/Airtime Fairness are not enabled. That the router supports Multicast & Broadcast Data (IGMP) across the LAN and that either of the WiFi adapters are not isolated from the other network segments (that’s if the SSID’s are the same) and also check that the DHCP server is enabled and working and has addresses available. (reboot the router too, if necessary).

See if that then fixes your issue.