Answered

Sonos Surround Set up Stereo PCM

  • 23 April 2023
  • 5 replies
  • 2076 views

 

I recently purchased a Sonos Arc, Gen3 Sub and 2 ERA 300 speakers. 

My wife and I watch a lot of movies and listen to music and when playing music the sound from these speakers is fantastic! 

 

When listening to movies the sound is slightly underwhelming but I suspect this is due to incorrect settings. 

 

I have the Arc connected to my Samsung TV  using the ARC HDMI cable into the ARC HDMI port. 

My Sky box is connected by HDMI to the TV and we watch films through this box using the onboard apps, Netflix and Amazon Prime.

 

The speakers have been tuned with Trueplay and all work yet when watching movies, the Sonos app always shows Tv playing Stereo PCM. 

I’ve found various Atmos films but it always stays as Stereo PCM.

 

I have tried various settings under the sound option on my TV.

Under DTV Audio, I’ve left this as ‘Auto’ because changing any of these settings doesn’t seem to make much difference.

 

On the ‘Sound Out’ there are two options - Auto or PCM. Again I have tried both of these but have left it on Auto for now. 

 

 

 

When a film is on, the rear speakers are so low they can’t be heard. If I put my ear next to it, I can just about hear it. 

The only thing I found makes any difference is under ‘Surround Audio’ to turn up the TV level which increases the sound from the rear speakers.

 

 

Looking online, several people have experienced the same problem but I’m hoping that someone can shed some light on this and help getting it set up correctly. 

 

Sorry for the long post. 

 

Thanks

icon

Best answer by GuitarSuperstar 24 April 2023, 03:35

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

 

Userlevel 7

Your TV is an LG not a Samsung. Do you know what specific LG model it is?

 

Set the TV settings to this (if available):

HDMI Input Audio Format: Bitstream (this could be located under “Additional Settings”)

Digital Sound Out: Pass Through (or Auto if Pass Through isn’t available)

DTV Audio Setting: Auto (or Dolby Digital Plus)

 

Set the Sky Q to this setting:

Digital audio output HDMI: Dolby Digital Plus

You are correct, it’s is an LG, the Samsung is in the Lounge. 
the model number is OLED65B8PLA.

 

hope this helps.

Userlevel 7

Have you tried the settings I posted above? Do the new settings make any difference?

I’ve changed the above settings apart from this one - which I can’t find. 
 

HDMI Input Audio Format: Bitstream (this could be located under “Additional Settings”)

 

After changing the other 2 settings It now shows as Dolby digital 2.0 or 5.1 depending on what is on the TV. I’ll check it again this evening and see if I can get Dolby digital and check what the sound quality is like.