Answered

Sonos One connected to system but not broadcasting sound

  • 11 January 2024
  • 3 replies
  • 325 views

Userlevel 1

.: Greetings. I’ve had a Sonos Arc SL and two Sonos One SL speakers for 1-2 years now. When I watch cable or streaming services, I always heard full surround sound. Then a couple of days ago, the One speakers stopped broadcasting any sound at all. I searched for solutions on the Interwebs and nothing I found solved the problem. Then I tried the Factory Reset, and used TruePlay to configure the surround sound in my living room. Everything sounded good with Trueplay having reconfigured the One SL speakers.

Then I tried various shows on Netflix, Prime, Apple TV+, etc., and no sound came out of the One SL speakers.

One other note: Up until a couple days ago, when I muted the sound on my flat-screen tv, the lights on the top of the One SL speakers would turn green. Now when I do it, they remain white.

I am at a loss. I have no idea what else to try and no idea what to do now. If anyone has an idea that might solve this, please let me know. This is SO frustrating. Thank you in advance for your help and guidance.

icon

Best answer by GuitarSuperstar 11 January 2024, 01:28

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Userlevel 1

Hello again, GuitarSuperstar. I returned home 30 minutes ago and followed your instructions carefully. Everything is now working fine. The Sonos One speakers are providing surround sound again. Thank you SO MUCH for taking the time to help me solve this problem. I am extremely grateful to you for taking the time to help me out, and I will not forget your kindness and generosity. Have a lovely evening.

Userlevel 1

GuitarSuperstar: Thank you very much for your reply. I am away from my home for the next few hours. I will follow your instructions when I return and report back afterwards.

Userlevel 7

Try this:

Remove the One SLs as surrounds in the Sonos app. Disconnect everything from the TV and unplug the Arc and TV from power for a couple of minutes. Plug everything back in but keep everything disconnected. Make sure CEC is enabled in the TV settings. Run TV Setup in the Sonos app and follow the app instructions. When the app instructs you, connect the Arc to the TV’s HDMI ARC port using the Sonos-supplied HDMI cable. After the Arc has been successfully connected, connect any other devices to the TV. Then re-add the One SLs as surrounds.