Answered

Dolby Atmos

  • 2 April 2024
  • 8 replies
  • 134 views

I’ve recently bought a Samsung S90c tv which has been great. I have a Sonos Arc that is connected to eArc, set to pass-through. I stream through my AppleTV box. Everything works great until I watch something has Dolby Atmos available, which I then get no sound on. Netflix, AppleTV, Disney etc. any help would be greatly appreciated! Thank you everyone 

icon

Best answer by Schlumpf 4 April 2024, 11:27

View original

8 replies

Userlevel 7
Badge +16

@Magnaflux 

TV digital audio input is set to bitstream?

ATV audio settings are „change format“ off and „dolby atmos“ on?

Tv digital audio is set to pass-through, Apple Tv settings are “change format-off” and “Dolby Atmos-on”. Still not getting Atmos sound 

Userlevel 7
Badge +16

Tv digital audio is set to pass-through, Apple Tv settings are “change format-off” and “Dolby Atmos-on”. Still not getting Atmos sound 

There should be TWO audio options on your TV. One has to be set to passthrough and the other to bitstream. 
If you like, post some screenshots of your audio settings here. 
The settings and their names vary from TV to TV. 

Userlevel 7
Badge +18

Don’t forget to check the program is being transmitted in Atmos - not all are more than stereo/DD2.0

Userlevel 7
Badge +16

@Magnaflux 

Regarding to what @nik9669a said I suggest to test with AppleTV+ which is part of your used services. They offer a huge number of titles in different languages with Atmos audio. 

Tv digital audio is set to pass-through, Apple Tv settings are “change format-off” and “Dolby Atmos-on”. Still not getting Atmos sound 

There should be TWO audio options on your TV. One has to be set to passthrough and the other to bitstream. 
If you like, post some screenshots of your audio settings here. 
The settings and their names vary from TV to TV. 


 

Here is my audio settings. I can’t find the second option though, just pass-through

Sorry I accidentally clicked yours as the answer to the question, not sure how to undo it

Userlevel 7
Badge +16

Sorry I accidentally clicked yours as the answer to the question, not sure how to undo it

Seems a mod has done… 😎

 

Regarding your problem… if there’s no other audio option available on your tv, it might be a tv software problem. There were some Samsung tv in the past having issues with Atmos/ eARC. Please check your tv firmware version and look for an update at Samsungs support on the web. 
What you also can try to do is:

  • switch eARC from auto to on
  • turn off „Anynet+“, disconnect hdmi cable from Arc on tv input, restart tv, turn on Anynet+ and reconnect hdmi cable

If all of that doesn’t work, please call Sonos support team. 
https://support.sonos.com/en-us/contact

Reply