Can't get 5.1 surround sound from all of the streaming services

  • 22 April 2021
  • 1 reply
  • 579 views

My set up:
Internet and TV Provider = Cox
TV = Vizio E600i-B3
Streaming Device = TiVo Stream 4K with Android TV
Surround Sound system = Sonos Beam with 2 Play 1s and a Sub

Settings:
TV speakers are set to "OFF" and digital output is set to "Bitstream" per the TV instructions to get multi-channel audio.

Sonos equipment is currently connected to the Optical output of the TV, but I had it connected to the HDMI ARC (HDMI 1) output and I get the same results. I use the Optical because the Sonos can use either output and I need the HDMI ARC connection for a different piece of equipment AND the TV instructions say that Optical can deliver multichannel audio.

TiVo Stream 4K is connected to HDMI 3 and in the Audio setting I have every audio profile turned on.

The test movies I am using are Zach Snyder's Justice League, Godzilla V Kong and Aquaman on HBO Max.

I get full surround from Aquaman and on the title screen the audio is listed as 5.1

I do not get any rear sound from the other two movies and they are listed as Dolby Atmos so it seems that the DD+ is being converted to PCM Stereo 2.0.

The Beam is rated for Dolby Digital 5.1 but it is not rated for Dolby Digital Plus (Atmos).

Is there a setting I am missing that will convert DD+ to DD5.1 for my system?

Also, on the Disney+ app, I get nothing in DD5.1 - everything is in PCM Stereo 2.0.


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Userlevel 7

Since the Beam doesn’t support Dolby Atmos, Dolby Digital Plus, DTS, or Dolby TrueHD, turn those audio formats off on the TiVo and see if that makes a difference.