Arc Echo with multichannel

  • 18 April 2023
  • 6 replies

  • Contributor I
  • 4 replies

Hello Community:

i am using a Philips Ambilight TV 55OLED805/12 with an Arc via HDMI and 2 Solo One SL for Surround. All on a strong WiFi.
I am experiencing an echo if I put my advanced audio setting on the TV to Multichannel or Multichannel (Bypass). Turning the surround off via the app does noch resolve the issue and the echo is very notable on the Arc, especially with people talking. If I turn advanced audio setting on the TV to Stereo the echo disappears. 
Any guidance how I can use Multichannel without experiencing an echo?

Appreciate all answers and advice upfront. Thanks Martin 


Best answer by GuitarSuperstar 18 April 2023, 22:48

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Userlevel 7

Have the two One SLs been added to the Arc as surround speakers or are they just grouped with the Arc in the Sonos app?

Have the TV speakers been disabled in the TV settings?

Hello Rashi. Yes Sonos One SL have been added as Surround to the Arc and TV speaker is disabled. 

And maybe I should add that I use Apple TV if there is another setting I might have not discovered to give attention to….

Userlevel 7

Keep the Philips TV set to Multichannel (bypass).

Set the Change Format audio setting on the Apple TV to ON. Set the Audio Format to Dolby Digital 5.1.


If those settings don’t help, try this:

Disconnect everything from the TV and unplug the Arc and TV from power for a couple of minutes. Plug everything back in but keep everything disconnected. Make sure EasyLink is enabled in the TV settings. Run TV Setup in the Sonos app and follow the app instructions. When the app instructs you, connect the Arc to the TV’s HDMI ARC port using the Sonos-supplied HDMI cable. After the Arc has been successfully connected, connect the Apple TV to the TV.

Thanks Rashi. Appears I have all set up correctly and you advice to set up again whichever will do. Will report if this fixed the issue. Thx

Reset all and it worked. Hope it will stay like this. Thx for the help Rashi!