Answered

Amp not working with Playbar

  • 31 May 2023
  • 7 replies
  • 116 views

I have 2 sets of Sonos architectural in ceiling speakers connected to 2 Sonos Amps in 2 separate rooms.  In one room I have a Sonos Arc and was able to have the ceiling speakers attached to the Amp get set up fine as surrounds.  In the other room I have an old playbar and was trying to set up the other Amp as surrounds with the playbar.  Got it setup and seemed to be working fine for a few minutes and then noticed that system said it could not fine the Amp.  Nothing in the app seemed to work to get the Amp to reconnect but playbar itself remained working.  Tried to take the Amp off as surrounds but system still would not find the Amp again.  Had to hard reset the Amp and setup Amp again as standalone speaker.  Tried second time to setup as surrounds and same result only Amp became disconnected almost immediately and had to do hard reset again.  Realize the playbar is a bit older and amp is brand new but seems others have gotten amps and playbar to work together.  Any suggestions on things to try?

icon

Best answer by buzz 31 May 2023, 20:06

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

We could argue that ARC has improved radios, compared to PLAYBAR, but this does not guarantee enough improvements to resolve your situation. It’s possible that relocating AMP a few inches will help if this results in a more direct path to PLAYBAR. If AMP is currently inside a cabinet, moving AMP out of the cabinet will help. Also, humans are essentially bags of water and water absorbs WiFi energy. You may be able to improve the situation for regular use, but during a party the extra water bags might impede communication. Elevating AMP above the water bag clutter will help.

Finally, if you can wire both AMP and PLAYBAR to the network, they will not attempt to use the 5GHz link.

I am connected both to nerwork and at least at the moment they seem to be working.  Thanks for suggestions as would not have thought to try connecting them. 

Userlevel 7

How far is the Amp from the Playbar? Are they both located in the same room? Is the Amp in an enclosed cabinet? Is the Playbar or Amp wired with an ethernet cable?

Playbar connected by optical wire to tv but wireless to internet via Sonos boost. Amp wireless as well and sits next to the boost in a cabinet. The Amp is 40-50 feet from the playbar. 

AMP is attempting to use a private 5GHz connection to PLAYBAR. Walls and distance will reduce signal strength.

I will see if I can get closer but not too much I can do. Do beam and/or arc work same way. If I can't get it to work would upgrading felp or would I just have same problem?

Thanks for the help. 

Userlevel 7
Badge +17

All Sonos soundbars use a dedicated 5Ghz link between soundbar and surounds.