HDFury Vrroom, Panasonic UB820, Sonos Arc, Epson Projector

  • 23 February 2024
  • 2 replies
  • 88 views

Hi, my setup is: HDFury Vrroom, Panasonic UB820, Sonos Arc, Epson Projector. 

The settings on UB820, under “Digital Audio Out”: 1) Dolby: bitstream, 2) DTS: bitstream or PCM (same result), 3) Secondary Audio: Off or Auto.  When I play DTS-HD bluray, I get no sound.  On the Sonos S2 App, it says “silent 7.1”.  If I switch the Secondary Audio (on UB820) to ON, I get DTS Surround 5.1.  However, if I play Dolby Atmos bluray, I only get Dolby Digital 5.1, and no Dolby Atmos.  I can only get Dolby Atmos, if I set the “Secondary Audio” to Off.

Any help is appreciated.

Thanks!


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Userlevel 7

Secondary Audio must always be set to OFF when playing a disc with Dolby Atmos audio. This is normal. I believe the same applies to any lossless audio formats including DTS-HD Master Audio (which is not supported by Sonos) and Multichannel PCM.

If you want the core lossy Dolby Digital or DTS Digital Surround tracks to play, set Secondary Audio to ON.

Does the VRROOM have any LPCM settings you can adjust?

When you play a disc with Dolby Atmos audio, what audio format does it display under the Arc information after “Audio In:” under System > About My System in the Sonos app? Does it say “Dolby Atmos (TrueHD)” or “Dolby Atmos (DD+)”?

@GuitarSuperstar: thanks for your reply.

  1. When I play a disc with Dolby Atmos, I get Atmos (per Sonos S2 App).
  2. I think I might have found a root cause. UB820 converts DTS-HD into PCM or sends DTS-HD as bitstream both at 192kHz, but the Sonos Arc can only handle 48kHz.  I do not know how to set the UB820 to output 48kHz (when it’s DTS-HD).  I’m looking into how to set the VRROOM to limit L-PCM at 48kHz.