Trouble adding Google Assistant to Arc

  • 6 February 2021
  • 9 replies

  • Contributor I
  • 4 replies

Having trouble adding the google assistant to arc. No issues adding to move or one. the google assistant app just says “no device found” when i try to add to my arc...

All devices on same wifi set up.

Have already tried factory reset, unlinking and relinking sonos account to google assistant. Super frustrating as I want to use my ones as surrounds with the arc but not lose the google assistant. 


any tips?


Best answer by GuitarSuperstar 9 February 2021, 16:49

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

9 replies

Thanks so much! Following the guidance in that thread fixed it for me. 

Well, I was able to finally add it. Not sure I did anything differently. However now the Google assistant will often chime now on the arc when i say “ok google”, but fails to answer a question or perform commands. And after a while of being non responsive then says “sorry I’m having trouble”. Arc is connected to Wi-Fi, and my television via eArc. 

seems unlikely to be the router, as other Sonos products have no problem with the Google voice assistant. Any thoughts or tips?

Userlevel 7

What router are you using?

Had lot of problem witth this, did clear my data and cash for Google home and sonos, then opened Google home and linked sonons again. This finally sovled my problem! 


Prior to this I had changed this settings. After clearing the data an cash this solved my problem.


Inställningar för ASUS:

På vänster sida klicka på Wireless

General/ Band 2.4GHz:

-Trådlöst läge -> Legacy
-Kanal bandbredd -> 20 MHz
-Authentication Method -> WPA2-Personal
-WPA Encryption-> AES
Tryck verkställ

Wireless / Wireless MAC Filter
-Enable MAC Filter-No 

Wireless/ Professional:

-Roaming assistant  --> Inaktivera
-Enable IGMP Snooping --> Aktivera
-Airtime Fairness  --> Inaktivera  på 2.4GHz och 5GHz
-Universal Beamforming/ Universal strålformning --> Inaktivera på 2.4GHz och 5GHz
Tryck verkställ

På vänster sida klicka på LAN och efter IPTV
-->Enable Multicast routing (IGMP Proxy) - Aktivera
-->Efficient Multicast Forwarding (IGMP Snooping)- Aktivera
Tryck verkställ

Starta om alla högtalare efter att dessa inställningar har gjorts/kollats för bästa resultat.


Mod Edit: Added English translation

ASUS settings:

On the left side click on Wireless

General / Band 2.4GHz:

-Wireless Mode -> Legacy
-Channel bandwidth -> 20 MHz
-Authentication Method -> WPA2-Personal
-WPA Encryption-> AES
Press apply

Wireless / Wireless MAC Filter
-Enable MAC Filter-No

Wireless / Professional:

-Roaming assistant -> Disable
-Enable IGMP Snooping -> Enable
-Airtime Fairness -> Disable at 2.4GHz and 5GHz
-Universal Beamforming / Universal Beamforming -> Disable at 2.4GHz and 5GHz
Press apply

On the left side click on LAN and after IPTV
-> Enable Multicast routing (IGMP Proxy) - Enable
-> Efficient Multicast Forwarding (IGMP Snooping) - Enable
Press apply

Restart all speakers after these settings have been made / checked for best results.

Asus ZenWiFi XT8. 

Userlevel 7

There are many users who have your router who have experienced connection issues since the latest router firmware update. Some have fixed their problems by reverting back to the previous firmware. Read through this thread: 


Userlevel 7

What happens when you add Google Assistant to the Arc through the Sonos app?

Sorry, i may not have been so clear. I am trying to add through the sonos app and when the sonos app switches to the google assistant I receive the message “No devices found”

Userlevel 7

Try going to Settings > App Preferences > and tap Reset App and close and re-open the Sonos app. Also try removing your Ones as surrounds from your Arc and remove Google Assistant from your Ones before adding Google Assistant to the Arc.