Question

Sonos not working on Google Assistant

  • 28 August 2019
  • 21 replies
  • 8799 views

The voice service used to work very well before using my phone and then just stopped working. I went and bought a google home mini to see if that would work but same result. I have reset everything but still no result. I have a google play subscription

I say " OK Google, play classical music in the living room". response is "alright, classical music from google play playing on living room, sorry I'm not sure how to help you yet" and "sorry I cant help with that yet". I have also tried to play in the kitchen (I have Sonos play 1 in the kitchen as well), but the same response. I have tried to unlink the service from my phone and use my tablet instead , but same responses. Google home app shows the speaker connected through sonos in the living room and kitchen.
I have contacted the tech support but have had no luck yet

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

21 replies

Do Sonos support teams read these threads? it would be nice if they popped in and gave us updates.  this problem makes me want to abandon Sonos and switch to samsung or bose …. but i really dont want to do that 

 

Same

As I wrote this the service is working again. It has been months since the last time I used it. I’m curious if it is working for you guys as well!

OMG it works again!! Thank you for the heads up dude.  This new brought music to my ears ;)

Do Sonos support teams read these threads? it would be nice if they popped in and gave us updates.  this problem makes me want to abandon Sonos and switch to samsung or bose …. but i really dont want to do that 

 

Same

As I wrote this the service is working again. It has been months since the last time I used it. I’m curious if it is working for you guys as well!

Do Sonos support teams read these threads? it would be nice if they popped in and gave us updates.  this problem makes me want to abandon Sonos and switch to samsung or bose …. but i really dont want to do that 

 

Same

Do Sonos support teams read these threads? it would be nice if they popped in and gave us updates.  this problem makes me want to abandon Sonos and switch to samsung or bose …. but i really dont want to do that 

The Staff do pop along here from time to time, but it’s mainly a community platform for 'other' Sonos users to discuss things and help one another. If you are looking for Sonos Customer Care, then you need to go HERE and choose a contact method, some links provide 24/7 access.

Do Sonos support teams read these threads? it would be nice if they popped in and gave us updates.  this problem makes me want to abandon Sonos and switch to samsung or bose …. but i really dont want to do that 

 

I’m having the same problem. I have a Sonos One.

My Google Home Mini is having no such problem.

I called sonos and got the same answer, very frustrating.  I had to create a second account just for my sonos, and test my actual one from time to time. As of this morning, no joy. 

Userlevel 1
Badge
Unfortunately I've already been down that road, and my correspondence with Sonos has stalled as they seem to be awaiting resolution from Google.

"Thank you for the check-in. This issue has been reported and acknowledged by the Google partner engineering team since September 4th. We currently do not have any update on the case as the issue is still being worked by our partner.

I will notify you as soon as we receive any progress update from the partner, Google. "
No change after the status is back up. I suspect that this won't be resolved until Google and Sonos figure out their integration problems.
It’s still working okay here for me. I have GA on both a Sonos One and the new 'Move' device. I would perhaps contact Sonos Customer Care in your particular country/region to try to get it resolved over the phone.
Userlevel 1
Badge
No change after the status is back up. I suspect that this won't be resolved until Google and Sonos figure out their integration problems.
Thanks for the description, but I've tried the same process a few times to no success.
Just by coincidence the service is down at the moment ... see the Sonos Status Page. Wait for that to show the issue is resolved and then perhaps try again.
Userlevel 1
Badge
Thanks for the description, but I've tried the same process a few times to no success.
I solved this issue myself by going to the Sonos App “Settings/Services/Voice/Google Assistant” and removing the assistant from each one of my Sonos Products.

I then opened the Google Home App and unlinked the Sonos Device/Skill... this can be found by selecting the Add (+) option at top of screen and then choose “setup device/have something already setup”. The top section of the list shows the devices/skills installed/linked and the lower “add new” area, is a list of other available devices and skills not yet linked etc.

i waited a minute or two for Sonos Device to unlink and then checked the Google Home main page to ensure all the speakers had completely disappeared from my Google rooms.

i then fully closed both the Google Home and Sonos Apps.

I then re-opened the Google Home App and reinstalled the Sonos Device Skill, agreeing to the sharing agreement and it scanned and found all my speakers again and placed them into the rooms of my Google Home. At this point I chose to move a few of my speakers about and place them in other Google rooms of the Home, just so they were where I wanted them.

I ensured there was only one default Location/Language set in the App. In my case that was English (United Kingdom). I believe having more than one language or indeed more than one Google Home can often be problematic.

I then checked that my default music sevice was correctly set in the App... that was Deezer Premium in my case. I understand that the free services like Spotify (Free) don’t work.

I then closed the Google App and opened the Sonos App and ensured the same Deezer Premium Music Account was installed there too. I also checked my online Sonos Account Profile (https://www.sonos.com/myaccount/user/profile/) was set to the same location/language/country settings (English United Kingdom) in my particular case.

Finally, I went back to the Sonos App “Settings/Services/Voice/Google Assistant/Add to another Product” and added the Assistant to each of my chosen Sonos devices. I did them one at a time and after that everything has worked perfectly for me.

Anyhow I hope that information will assist others here to get things working.
Userlevel 1
Badge
I’ve definitely been reluctant to buy more Sonos products because of this.
This is a big deal for me and will negative impact on Sonos. Google or not, third party or not, This is a big deal for me. I have almost every product they make, and every room with a Sonos 1 in some capacity, however, For me, this is unacceptable. This has been going on for months and I am at a point where I have considered replacing all my Sonos Equipment. I am going to open a support ticket and try to resolve, however, this is very frustrating. Please post if there has been any progress from anyone else, or if there are any other options than a new google account which is just silly to suggest.
Same problem here. Will contact support also and try to highlight that this is not a single user problem. Setting up a separate Google account to get assistant working is not an option.
Userlevel 3
Badge +1
You've entered the third party blame loop. Google Assistant integrations are generally developed by the third party, so they often need to fix the issues. We know the Sonos integration was a closer partnership though, so if we can't get issues sorted out there really isn't any hope for any of the others...
I'm having the same issue. Sonos support had me replace my Google account with a new account and it fixed the problem. Obviously this isn't a solution but it pointed to Google being the issue. Anyway, Sonos punted this to Google for support. Google told me that they don't offer support for Google Assistant (only Google Home products) and said I should contact Sonos.

It sort of seems this one won't be fixed 😞
Userlevel 1
Badge
From what I've been told this is an ongoing open issue that seems specific to certain Google accounts, awaiting resolution from Google. I've been using Alexa in the meantime.
Userlevel 1
Badge
Been having the same problem for a while. Called in, wasn't able to resolve and got escalated to tier-2 support, which I had to make an appointment for. Google Assistant responds to other requests that require an internet connect (weather, business hours, etc) but no luck with any music streaming (Google Play, Spotify). Will update here if I find a resolution after the scheduled tier-2 support call.
I’m having the same issue. Everything worked fine up until yesterday. Very frustrating. Rebooted, updated software, disconnected Google from Spotify (and vice versa) and re-connected. No luck.
Userlevel 2
I’m having the same problem. I have a Sonos One.

My Google Home Mini is having no such problem.