google assistant doesn't work properly in the uk

  • 4 August 2019
  • 2 replies

Googlr is not working in Sonos one gen 2 .

Before I was using Alexa and is was working okay. But Google became available so I change to Google, but Google is not responding to my requests. All it can do is play and stop the music and that only sometimes.

I am the only one that has this problem?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

I had the same issue, I finally got this solved by pausing the Voice & Audio Activity controls within google itself... The sonos device seems to be working again now
I’m in the U.K. and my Google Assistant is working fine on a Sonos One (Gen2) stereo pair. Can I suggest the following...

Start with a single Google Home in your Google account. Make sure it just has one language installed.. English (United Kingdom). Check that language is also installed in your Sonos Profile.

Set your chosen Music subscription service as the default service for GA. (Not relevant in some circumstances)

Goto your Google Assistant App Settings/Home Tab/(+ Add...) and remove the Sonos Device Card. Wait till all speakers have been removed from the Home and then add the Sonos Device Card again and let it detect your speakers... ensure the speakers are correctly set in your chosen 'Rooms' in the GA/GH App(s).

Now goto the Sonos App Room Settings/Voice Services for the Sonos One ..and re-add the Google Assistant to the speaker.

If applicable, ensure that the chosen default music subscription service set in GA App, is also installed in the Sonos App with the exact same login credentials.

Then try things again to see if it works.