Unable to play - Connection to Spotify was lost

  • 15 December 2020
  • 9 replies
  • 3197 views

As the title says, I have a problem playing anything from Spotify.

 

So far I have tried following:

  1. Connecting my Sonos Play 1 with wifi
  2. Connecting it with wire
  3. Restarting Sonos
  4. Restarting the router
  5. Deleting spotify account in Sonos appa and adding it again
  6. Deezer working perfectly
  7. Radio stations work perfectly
  8. Spotify on my phone works perfectly
  9. Spotify on my PC works perfectly
  10. If I try to play music from spotify app, it stucks at connecting to my living room speker and nothing happens
  11. Clearing the Queue didn’t helped
  12. Updated both Sonos and my application to the last versions
  13. Spotify free was tested mybe month ago and it was working, now i paid for premium and it doesn’t work

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

9 replies

If you click on the link she provided, you should be taken to a page that has a link that says:

Chat With Us

Available Weekdays 10:00 am - 9:30 pm, Weekends 10:00 am - 6:00 pm EST

There are representatives available to chat.

 

That may only be on the page during those times, I don’t know offhand. 

Is there a WhatsApp number or Live Chat?

Userlevel 5
Badge +16

Hi there @tenomer.

Thanks for your very detailed response. 

We appreciate the time and effort you've spent troubleshooting with us, but at this point, it would be best to reach out to Sonos Supportso we can take a closer look at this in real-time and expedite the process. 

I suggest our phone team for they have more resources available on their system for advanced troubleshooting, and the tools our agents can use would be very useful in this case, there can be an advantage if they need to remote into the controller to see what's going on.

 

If you have any questions, please feel free to let us know.

Hi @Annazel S,

I have tried to change the channel, without any luck.

Below are the answers to the rest of your questions:

  • May I have the make and model number of any wireless router and/or Access Point that exist on the network?  It’s best if we can check any known issues or if there’s an additional configuration needed on the device.

Router is ZTE 4G Wirelles Router - MF286R

I’m also using D-Link DAP-1620 in another room to extend my signal but Sonos is connected straight to the router.

  • Please indicate also how these devices are connected to one another (wired or wireless).

Wired, with CAT-5e, 1m cable. Have also tried different cable and wifi.

  • If you are using a local WiFi network with more than one WiFi hub or access point, I recommend that you can try to switch your system toSonosNet by wiring Sonos device to your primary WiFi hub or router, that begins the WiFi network.

I’m also using D-Link DAP-1620 in another room to extend my signal which I tried to turn off just in case that is causing some interference. Didn’t helped. 

 

All other services are working fine. So It’s an issue only with Spotify.

It is working on my phone, but not in my Sonos.

 

 

Userlevel 5
Badge +16

Hi @eduardo1.

Thanks for reaching out, let me check it for you.

Kindly reproduce the issue, then submit a diagnostic report through the Sonos app shortly after the issue occurs, and reply with the confirmation number. I'd start by reviewing your system as well as the status of the devices, it will help in identifying what's possibly causing the issue.

 

Looking forward to hearing from you soon.

Userlevel 5
Badge +16

Hi @tenomer.

Thanks for your response and effort in submitting the diagnostic.

Upon checking the diagnostic report, there’s multiple transport error that was detected by the system due to the loss of connection to the Spotify server.

You may check this article that will help you reduce wireless interference around your Sonos products that commonly causes this issue.

If that doesn’t help, then knowing how and through what Sonos is connecting is the great foundation to troubleshooting this successfully.

  • May I have the make and model number of any wireless router and/or Access Point that exist on the network?  It’s best if we can check any known issues or if there’s an additional configuration needed on the device.

  • Please indicate also how these devices are connected to one another (wired or wireless).

  • If you are using a local WiFi network with more than one WiFi hub or access point, I recommend that you can try to switch your system toSonosNet by wiring Sonos device to your primary WiFi hub or router, that begins the WiFi network.

 

Let me know how that goes.

same issue. 

 

on play1. not able to reproduce music from Spotify. I tried on Spotify app, on Sonos app in both it fails. have around 1 week with the issue. tried same steps.

 

I can play Spotify on Amazon echo. I can play Amazon music, tunein on Sonos. just Spotify doesnt connect. it shows as available but music displays not able to reproduce.

Done: Your confirmation number is: 420746880.

Userlevel 5
Badge +16

Hi there @tenomer.

Thanks for reaching out and welcome to the community! Let me see what I can do to help you.

I appreciate the steps you did and to better understand what’s going on, can you reproduce the issue, then submit a diagnostic report through the Sonos app shortly after the issue occurs, and reply with the confirmation number. I'd start by reviewing your system as well as the status of the devices, it will help in identifying what's possibly causing the issue.

 

Looking forward to hearing from you soon.