Sonos Radio 'unable to play'

  • 6 October 2021
  • 3 replies

Userlevel 5
Badge +8

Selecting something from Sonos Radio in the app (Android) produces the pop up message “Unable to play ‘Sonos Radio’. Connection to ‘Sonos Radio’ lost”. Suggests I check my internet connection. Same message on another device.

In the Windows app it also fails, but suggests that I might need to reauthorize my Sonos devices. Trying that in the Android app under the Sonos Radio service setup, I just get “failed”.

So I tried the usual thing - unplug and re-plug the speakers to reboot. Then try re-authorizing Sonos Radio again. Now it works.

Typical Sonos. Got to love those informative error messages. I hear Sonos consulted the ancient Greek Oracle of Delphi for advice on proving clear messages. :)

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Userlevel 5
Badge +8

I’ve been down the road of consulting Sonos support and providing system diagnostics several times before about other issues, and sadly I have to say that it has always been a waste of everyone’s time. I don’t want to criticize the willingness of Sonos support staff to try to help, or the common sense of getting a system diagnostic from the customer as a first step. That’s always good. But Sonus support staff seem to be let down by a poor problem-tracking system that leaves them unaware of known problems that have already been reported for months by many people.

I also understand why off-base generic catch-all error messages occur. But they almost always represent developer laziness and deserve to be criticized every time they come up. In this case the problem is that the Sonos Radio service has un-authorized itself for this user account for no obvious reason. Surely that should be the first check and error message ahead of reporting it as internet connection lost, which is clearly wrong.

Having same issue submitted diagnostics. 160129714

Badge +17

Hi @Doug Ames,


I’m glad you were able to resolve the issue in the end. 


If this issue reoccurs, I suggest submitting a system diagnostic before troubleshooting it yourself, and sharing the confirmation number in this thread, or with our customer care team.

It would also be worth noting if the issue is just with one station, or multiple, as well as the names of said stations so we can investigate and advise further.

Sarcasm aside, the error messages you’ve received could indicate a variety of network-based issues that aren’t necessarily known to the app, hence the generic connection lost message. A diagnostic report will often point us in the right direction as to where the issue might lie :slight_smile: