Sonos cannot connect to USB drive on TP-Link router

  • 30 November 2022
  • 11 replies

Cannot share USB audio files with SONOS v2 system
Model: TP-Link Archer C8  
Hardware Version: V3
Firmware Version: 1.1.3 Build 20220510 rel.32759(5553)

The USB drive plugged into the Archer C8 shows it is active in the Archer C8 advanced USB settings.  All files are shared with no login required.

The network address is:  \\\sda1\USB_Music

Windows explorer can find the music files OK and can play them,  but the SONOS v2 system cannot access the music library.

Sonos initially connects to the USB drive at the network address entered, but gives the error message below after about 10 seconds.

I have worked extensively with SONOS customer support, but they were unable to resolve this problem.  SONOS suspects a problem with the TP-Link Archer C8's implementation of SMB1 and/or SMB2 protocols.

I have tried sharing the USB drive with and without user login and password, but neither works.

I just updated this router to the latest version firmware, but that did not resolve this problem.

Any suggestions from other users would be welcomed.

SONOS Error messge below:


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

11 replies

Userlevel 7
Badge +18

Hi @gmendenh 

Thanks for your post!

We are aware of an issue whereby Sonos is unable to load the Music Library from a USB drive connected to a router and our developers are currently looking into it; however, there is currently no timeframe for a resolution. It seems likely that you are affected by this issue, though I cannot confirm. If you can configure the router to only use SMBv1, you may be able to skirt this issue.

However, we currently recommend customers connect to a computer or dedicated NAS for music library indexing. If you have SBC (Single Board Computer) like a Raspberry Pi, this would also serve well.

I hope this helps enough that you can look at alternatives, at least.



Thanks for your reply and partial explanation.  I was able to use the USB drive connected to my TP-Link C8 router before I upgraded from SONOS-1 system firmware to SONOS-2 firmware.  It worked fine with S1, but no longer works with S2.  Maybe this is a clue for your software developers.  I thought about reverting to S1 firmware, but I’m not sure it would be compatible with all the SONOS devices that I have added to my system since upgrading to S2.

I have worked with the technical support people at TP-Link and they were not able to offer a resolution other than to work with SONOS on this issue.

I hope the SONOS developers can make this issue a priority since there seems to be many others having this problem.  Having my music library available from a solid state, flash, drive is much more desirable than having to keep a computer running or to purchase a NAS just for this purpose.  I have a significant investment in SONOS equipment and would like all the systems features to work properly.

Please let me know when there is a firmware upgrade to fix this problem.

Thank you,


Userlevel 7
Badge +18

Hi @gmendenh 

I was able to use the USB drive connected to my TP-Link C8 router before I upgraded from SONOS-1 system firmware to SONOS-2 firmware.  It worked fine with S1, but no longer works with S2.

One difference between S1 and S2 is that S1 uses SMBv1 to communicate with external network shares, whereas S2 uses SMBv2/3. The issue I refer to only affects SMBv2/3 shares, so forcing Sonos to access your network share using SMBv1 should work. You can only force Sonos to do this from the SMB server settings, i.e. the router settings, so I am unable to give you instructions.

I have tagged this thread with the relevant issue tracking code and will update here when the issue has been resolved.



The latest firmware installed on my TP-Link C8 router no longer supports SMBv1, but it does support SMBv2, so I don’t understand why SONOS cannot read files from the USB drive or create an index from the USB drive.  I don’t believe that SONOS S2 needs write privileges to the USB drive.  It only needs to read from the USB drive.   As I mentioned in my earlier post,  SONOS does initially recognize the USB drive at the location I entered, but fails when it tries to access the files to play or to create an index of the music files on the USB drive.

Thanks for the follow-up. Geoff

Userlevel 7
Badge +18

Hi @gmendenh 

To be clear, this issue is a software bug that we aim to fix - there isn’t much sense to make as to why it doesn’t work.

I have the same issue. Please fix the issue on the next Sonos update

I may have solved the problem of the music library not connecting to USB, indexing etc. After weeks of effort, trial and error it came down, as always, to something simple and thought Sonos might have mentioned it when I spoke to them; or at least be more techincally aware than I am to, at least,  try it out. This refers to the message “Music Files Not Available” when trying to link to my USB stick in the router where I also store my music for sharing like others. The answer: After setting the path; e.g. \\\admin\music[ or whatever your router IP address is] , when Sonos looks  for the music files, if it encounters any “extranious” files (i.e. ones that do not have a “proper” music title incl. any iTunes library files) it fails and the “Music Files Not Available” message appears, like others have found, after a few seconds. If you “specifically” do not need the iTunes library files to be in that USB folder (e.g. do not copy over to the USB stick when setting up for Sonos share) then delete, in my case, all references to iTunes. Do not, obviously, delete it from the main music folder you are “copying from”. Just make sure it is not in the shared USB stick that will be inserted into the router. That and the misc. files mentioned earlier should all be deleted. So with a clean folder system of just pure music files the indexing takes place and after several attempts testing it, with several drive types [full hard drives and flash] it works pefectly. Hope this is clear, if a somewhat rambled explanation.


I tried obmuj’s recommended fix without success.  I have a TP-Link Archer C8 router which creates an index folder named .TPDLNA which contains a folder named ART_CACHE and a file named FILES.DB on the USB drive inserted in the router.

I removed the USB drive and deleted these folders and files.  I then removed any Apple iTunes files leaving just MP3 and WMA file types.

I inserted the USB drive back into the Archer C8 router. The router scanned the USB drive and recreated these database files.

I then tried to setup the USB drive as a music library source using the Sonos PC app, but it failed again with the “Music Files Not Available” message.



gmendenh. Sorry to hear that. I can only speak for my system. I use a mobile 4g router which just happens (not all do) to have a USB port unlike most mainstream routers that do not use cellular connection. To be frank the USB port used with a flash drive or external drive is pretty useless (slow) for copying or backing up files. However as I stated, I had a horrible time trying to jet the USB stick to index music on my Sonos in spite of the correct, mapped networth path; same error message as stated here - “Music Files Not Available”. All I can say is I stared at the screen for ages and thought…..”I wonder if…..” because the odd few files and folders (there were 4, one being iTunes and its sub folders) might, just might be the problem. I can only reiterate; I deleted those files incl. iTunes folder and hey presto, it indexed and completed; i.e. did not stop after a few seconds, as before. Worked for me but hey ho, probably won’t work if I try again but once the files have been indexed, if anyone else succeeds as I did, then my suggestion is - “Don’t touch it”. Of course you need to reindex if adding more music but my music folder is not really that sophisticated or needing much looking after.

PS: I thought I saw a note about Sonos stating this is a known problem so maybe we need to wait for an update.


obmuj, thanks for your response. 

The SONOS software team is aware of a software bug that is causing this problem and they plan to fix it, but it may not be a priority.

The music files on my USB flash drive worked perfectly under the SONOS-1 software version.

The problem started after I upgraded my system to SONOS-2 software version.


Hi all, just doing my 2 cents in.

I also have this problem.  Exactly.

TP-Link router providing 2.4GHz that I use for everything except my main TV. Internet is provided to TP-Link by ethernet from a NetComm modem at the other end of the house.

I had been using an unpowered external HDD as a fileshare.  It was unreliable and often wouldn't play.  Swapped a Seagate powered external HDD in for more capacity.  Removed the old share to set up a new one. Couldn't set up the media library. Tried the controller on my laptop and phone. Tried reconnecting the old HDD and I get the same error where it had been working just days ago.  No updates or changes as far a I'm aware (updates always cause chaos and orphan my phone controller).

I don't know how to check the SMBv1/v2 stuff yet or if be right in. Thought the problem was me 😀.

Very keen to hear of a fix. Hope this anecdote helps.