Sonos App Not Playing YTMusic or Sirius

  • 31 March 2024
  • 3 replies

I recently purchased a pair of Era 100’s, which I’ve been very happy with, but a few of the services I add to the Sonos App do not play. I have no issues with Spotify, Plex, Audacy, etc but I received an “Access Denied” error with SXM and “Unable to Play” with YTMusic.


Some of my troubleshooting steps:

  • deleted both services and re-added
  • Re-authorized both services
  • Rebooted Sonos system and my router
  • Changed my DNS
  • Tried to play via Windows and another device

Each troubleshooting attempt ends with the same error.


Any assistance would be greatly appreciated. Thanks!


Best answer by Airgetlam 31 March 2024, 04:15

View original

3 replies

Thanks, I'll give the diagnostic a shot. I confirmed that my location is set the the US.

Remember to call in after submitting that diagnostic. As discussed in the Diagnostics - How do they work? thread, they won’t look at it until you prompt them to. 

Log in to your account at, and make sure your location is set properly on your account. Some services use that as a filter.

If that doesn’t work, I would recommend that you submit a system diagnostic within 10 minutes of experiencing this problem, and call Sonos Support to discuss it.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your network and Sonos system.