Sonos App

  • 13 February 2024
  • 9 replies

When I open up my sonos app (android) i can’t add SiriusXM and the only music services showing are and TuneIn.  I don’t even see the standard sonos music (such at Cocktail hour etc.)  We are unable to play any music!  I uninstalled and reinstalled the app, signed into my account, etc.  My husband is also unable to access anything to play on the sonos app (IOS).  Right now all we have is a very expensive TV Soundbar.


Best answer by MarinCate 13 February 2024, 06:18

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

9 replies


Same issue, I could before, and they disappeared.

Same issue - what is up???


Just went from 7th to 8th in the queue so obvi their system is whacked out.  Hope it’s just a cloud system issue like was reported last fall (that I just read about on a board)

Thanks airgetlam - no new update in the App Store avail…


will try the next steps, thanks!


Try going to settings > system > system updates > check for updates. 

If that doesn’t fix the issue, I would recommend that you submit a system diagnostic within 10 minutes of experiencing this problem, and call Sonos Support to discuss it.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your network and Sonos system.


Calling Sonos is mute.  They have very limited hours.  I have auto update on updates so that is not the issue.  I had Google and Sirius working before and those options are gone and I am unable to add music.  


I just went in the app  → System →  Music Library  → Then Update Music Index Now. then the services that I previously had, I can now see to add.

Unplug all speakers wait 10 seconds - then plug back in… worked for me and now all services are selectable.  Also update firmware thru app… mine was auto updated but could be issue for you?


I posted what worked and didn't include unplugging every piece of equipment I own. Its a software / app issue not an equipment issue.

Oh wow, I’m glad that worked for you - wasn’t my issue - mine was an equipment connection.  I also have older speaker system so that’s prob an issue too.  If you need help, the chat was open and worked for me - they were patient and helpful and it was an actual person, not a bot, which I appreciated.