S1 app stopped working after iOS 16 upgrade

  • 22 November 2022
  • 3 replies

My S1 app cannot see my Sonos system after upgrade to iOS 16. I have tried reinstalling the app and turning network permissions on and off, but no matter which of my units (mix of new and old) I try to connect, it doesn’t find them. I had similar issues 1-2 years ago when the app suddenly started working again - after an update to one thing or the other I guess. Also my Sonos Move have stopped appearing in the list of Airplay devices on my phone in other apps.


Best answer by Jamie A 23 November 2022, 11:57

View original

3 replies

Userlevel 7
Badge +15

Hi @mhornbech,

Your guess would be as good as mine, without any troubleshooting performed we can’t narrow down to what the issue was.

My best bet would be that it was a network issue between your phone and router. Your Sonos system is running fine, so it’s likely after updating to iOS 16, your iPhone wasn’t communicating with your router correctly.

However, I am glad to hear that this has been resolved for you and you’re able to connect to your system again.


Userlevel 7
Badge +15

Hi @mhornbech, welcome to the Sonos Community!

Sometimes with updates, it can reset device settings if the update targeted those settings, so you may need to adjust your iOS device.

Can you check if both Location Services and Location Permissions are turned on in your settings? Apple have a guide on how to enable Location Services for specific Apps.

Also, I see you mention you tried turning network permissions on and off. After adjusting the location services, make sure Local Network in your settings is set to on.

I hope this information helps!

It spontaneously started working now - dont know why or how.