S1 app fails to create amazon and mixcloud service

  • 7 December 2020
  • 1 reply


I split my sonos system in 2.

So I now have 2 sonos5 gen1 devices on one s1 app and all the gen2 devices on the s2 app.

All good until I try to add music services to the S1 app.

Tried to add Amazon and mixcloud. Both services claim to be added succesfully until you return to Sonos S1 app where it indicates that the addition failed.

For mixcloud I tried a different account from my s2 account. That also failed. Is it an S1 issue ? Any suggestions on how to resolve.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Userlevel 5
Badge +14

Hi @rosspetx.

Welcome, thank you for reaching out to Sonos Community, We appreciate your time and effort in posting your concern here in our community.

I think this one falls under Known limitations with separate S1 and S2 Sonos systems under music services.

If you need help with any other information, please be sure to let us know.