Plex Media Server on Synology NAS suddenly unable to play 16bit 44.1kHz flac over SONOS

  • 1 April 2021
  • 9 replies

Userlevel 1

I’ve been using PLEX Media Server (PMS) running on a Synology Diskstation to serve up local music files to the household SONOS system. It has been working flawlessly until the last couple of days. Unfortunately, both the NAS software (including Disk Station Manager, v: 6.2.4-25556) and PMS (v1.22.1.4228) were updated during this time, so I’m not sure where the issue started, but this is what I’ve been able to establish:

  • PMS will play any mp3 file via either the Android and Windows desktop SONOS controllers (S2).

  • PMS fails to serve up almost all 16bit 44.1kHz flac files to SONOS and reports “Unable to play - the connection to Plex was lost.” This error is reported in both Android and Windows SONOS controllers. I have found only 2 flac files that will play and I can see in the PMS dashboard that they are being played as flac (stereo) at 834Kpbs and 941Kbps, respectively. However, all other tracks on the same album fail to play.

  • I have one album that is hi-res flac and it plays fine but --- as one would expect -- only because it is being transcoded to AAC (@271Kpbs).

  • PMS WILL play these problem flac files in a browser tab launched from the Synology dashboard as flac (“Direct Play” in the PMS dashboard). No problems there.

  • I should also mention that these flac files were purchased as “cd-quality” downloads in their current format (I did not rip or convert them in any way).

The weird thing is that these files played maybe 2 days ago(?) without issue. I’ve tried rescanning library files and running PMS’ Analyze function; and on the SONOS side, I’ve tried refreshing the music library. I’ve also restarted PMS and the SONOS controllers, rebooted our BOOST, all to no avail.

This isn’t a burning issue as 95% of my library is mp3. So, one solution might be to just sit tight and see if a PLEX update (they come pretty frequently) fixes the issue. I see others have had similar problems with PLEX and flac, from time to time, but I could find nothing in previous threads that provided a quick fix. Open to any suggestions.

Thanks much,



Best answer by mgenthner25 3 April 2021, 15:25

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

9 replies

If there was a firmware update on the Synology, it is quite likely that it turned off SMB v1, which is why the speakers can no longer get the music from the drive.

Note that it doesn’t explain why some files work, although if I understand your post, you’re accessing them via another app, and ‘casting’ that to the Sonos, whereas normally Sonos goes out to ‘get’ the data. It is at least a place to start.

Also, I’m not a Plex user, so I could be completely wrong.

Userlevel 1

Bruce, thanks for the reply. I looked to see if SMB settings had changed and they have not. As an aside, the Synology default settings disallow SMBv1 (I ran into this when first setting up the NAS) and while enabling SMBv1 initially allowed me to play local files over SONOS, things I read on this forum led me to think this was somewhat risky. That’s how I ended up using PLEX. Currently, the Synology’s “Minimum SMB Protocol” is set to SMB2, so I have to assume that however this works (and I’m admittedly sketchy on the details), the Synology-PLEX-SONOS connection isn’t using SMBv1.

When setting the PLEX server up, I was able to add PLEX as a music service, alongside Amazon Music, SiriusXM, Sonos Radio, etc. and when I browse on the Android controller, PLEX appears just as any other music service. After my initial post I thought -- Well, what happens if I put the unplayable flac files on my phone and just try to play them “On this Mobile Device” on SONOS? Sure enough, they play just fine.

So, now I know that PLEX can play the files when SONOS isn’t involved and SONOS can play the files when PLEX isn’t involved; and I’m assuming that something in one of the aforementioned software updates caused the issue. However, at this point, it seems a small issue and I think I’ll just wait out a few more software updates and see if the problem is somehow fixed.

Thanks again for you input.



 That’s how I ended up using PLEX. Currently, the Synology’s “Minimum SMB Protocol” is set to SMB2, so I have to assume that however this works (and I’m admittedly sketchy on the details), the Synology-PLEX-SONOS connection isn’t using SMBv1.


Unless I’m greatly mistaken, that’s correct.  SMBv.1 only matters when Sonos is reading your file system directly.   Plex essentially is a layer in between the file system and Sonos (or where ever your playing plex), so Sonos does not care about your file system or where it’s even stored.  In fact, I believe that Sonos streams Plex through the cloud rather than staying in your local network.

Userlevel 1

Thanks, Danny. Yes, there is a “Disable Remote Access” button in the PLEX dashboard and I found that when clicked, the PLEX-SONOS connection is broken. I can still see the PLEX service in my Android Controller but the only things that list below it are PLEX services -- podcasts, etc.. My local music library isn’t visible.

It gets more complicated in that there seem to be two states of web connection: One in which the media server is available from outside the network and the state that it is currently reporting where the PLEX dashboard’s “Remote Access” settings read “Not available outside your network. Your server is signed in to Plex, but is not reachable from outside your network.”  This may even be a bug but since I can play my local files in this state, I have just left it as is.


Userlevel 1

On the chance that this might help someone: I received notice of an update to the Plex Media Server, I installed the update ( but was still unable to play my 16bit flac files. Next, via the Synology Package Center, uninstalled the Plex software then reinstalled it and now I can play my flac files again. I do see that the reinstalled package is and while I’m already getting notice of an update, I going to sit on this for a while.


I have the same issue with PMS on a pc. Other flacs play fine, and work fine on my android and iOS devices 


Has anyone gotten this to work yet, I have the exact same problem. Music is in 16 bit flac, it is stored on an Intel NUC which literally does nothing else than wait for me to play some music.

Casting to Sonos will take 20-ish seconds to start, the song will pause after 9 seconds for another 10-ish seconds and then the song will play to end. It will not continue to the next song and you cannot skip.

The problem is the same to Sonos Beam (wireless) and Sonos Connect (wired). Playing music from a browser, casting to Chromecast or connecting to Plex through Denon Heos app works perfectly fine.

I have single album in mp3, it behaves the same way.

Playing music from Spotify, radio and some other services works fine.

Any pointers as what to try next is highly appreciated. Downgrading Plex to 1.18 for good sounds like a slippery slope tho :-)

Alright, so installed the plex plugin for the Sonos S2 app and that works as it should :thinking:

Guess I will be using that instead.



I am getting a very similar problems,


using Plex Media Server : plexmediaserver_1.24.1.4931-1a38e63c6_amd64.deb


and Sonos :

Sonos OS: S2
Version: 13.2 (build 64319080)
Hardware Version:
Series ID: A100
IP Address:
WM: 1


tried re-installing


Seeing these errors in the Server logs:

"playback in state 3 of type 10"


Very cryptic, I am unsure how to fix this.