Answered

Mac Book Pro M2 on Ventura 13.1 refused to let Sonos connect to it

  • 12 January 2023
  • 10 replies
  • 1001 views

Badge

Hi my newly purchased Mac Book Pro M2 running Ventura 13.1 shows this message when I try to connect to the folder containing my music “The computer “my MacBookPro” refused to let Sonos connect to it”.       I have installed the latest Sonos S2 controller.       I’ve checked the permissions on the folder.    Any suggestions would be very welcome.     Thanks

icon

Best answer by C M M 14 January 2023, 10:08

View original

10 replies

Badge

Pleased to report I’m up & running & have music playing through Sonos.

the issue was where I was storing our music - needs to be in the Apple Music app & can’t be in a folder (like it was on previous iMac)

Also changed the name of my MacBook to remove apostrophe and spaces.

Trial & error got there in the end.

Thanks for suggestions of what to try everyone

Badge

Spent 65 minutes with Sonos support yesterday but …

Might be worth reaching out to Sonos Support directly to discuss it, as well. They’re likely more familiar with the specifics. 

Hi.  I am not sure the term is used on Macs any more.  It is related to Windows file sharing.  I am not a Mac user, but this article may give you some clues.  Before you spend time on this though, something in the article made me think it would be worth removing the space from your computer name.  Then reboot the computer.

I’m not optimistic

https://support.apple.com/en-gb/guide/mac-help/mchlp1177/mac

Badge

I am not a Mac user, but I recall that in the past it was necessary for the “Computer name” and the “NetBios name” to be identical.  Not sure if that is still relevant but it used to trip up a few people.

Hi John, thanks for trying to help.  Where would I find the NetBios name please?

Badge

Further update. Sadly after playing one track, no longer connected & won’t reconnect.  V frustrating!  

Badge

Hi,   An update.   After 65 minutes on phone to Sonos support my music library is now connected to Sonos and playing.

The answer is in System Settings, Privacy and Security, Full Disk Access, and allow access for Sonos.

 

I am not a Mac user, but I recall that in the past it was necessary for the “Computer name” and the “NetBios name” to be identical.  Not sure if that is still relevant but it used to trip up a few people.

Badge

Hi,  Thanks

I’ve followed those steps in the how to guide.   I’ve asked Apple support who checked a couple of settings.  I’ve removed Sonos from my old iMac.  

On my new MacBook I’ve removed Sonos, restarted my router, installed Sonos again - just in case of some sort of clash.

I’m using the Sonos Mac controller.

I don’t know if any of these articles may help.

https://support.sonos.com/en-us/search?q=music+library

Are you using the Sonos Mac controller or the mobile app?

Reply