Lost Sirius connection - unable to browse music.

  • 5 October 2020
  • 3 replies

Just purchased Sonos system and within 4 days lost the ability to play Sirius XM - WHY? yes already uninstalled from Sonos and reinstalled still nothing.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Userlevel 5
Badge +16

Hi @Shasta36.

Thanks for your response and update. Sorry to hear about the trouble.

We would need to verify this time if there are any network/wireless issues on the system that could cause this.

Won’t you mind providing the make and model number of any wireless router and/or Access Point that exist on the network so I can check the compatibility or if there’s any known issue going on?

Kindly submit a diagnostic report through the Sonos app when the issue occurs, and reply with the confirmation number so I can review your system as well as the status of the devices, it will also help in identifying what's possibly causing the issue.


If you have any other questions or concerns, don’t hesitate to reach out, we’re always here to help.

Hi @Annazel S 

yes to all questions - I did check the status page and no outages plus I can play using my computer and the Sirius app on my phone with no issues. Even today I have the same issue - UNABLE TO BROWSE MUSIC. the other day I had the same issue and about an hour later the Sonos let me on Sirius with no issues but yesterday and today still cant’ get on.

Seems to be an issue with Sonos.


Userlevel 5
Badge +16

Hi @Shasta36.

Thanks for reaching out and welcome to the community!

I appreciate that you already tried to uninstall and re-install the app, I’d be glad to help further and try to figure this out.

The first thing I check is if there’s an ongoing outage here on the service status page, and so far the service should be operational.

Have you tried to play SiriusXM on the native app itself?

Is this happening on all your devices? 

What specifically is happening when you’re using the service within Sonos? Are you getting any error messages?

  • You may try to remove and re-add the music service and see if that works.
  • To check if this has something to do with the account, using a computer, can you please log on to the internet streaming website ( with the correct SiriusXM internet streaming credentials and let us know if you’re able to log in.


Hopefully, that helps but if not, please submit a diagnostic report, I'd start by reviewing your system and see if there’s anything causing this issue.


Let us know how it goes and if you have any questions feel free to reach out, we’re always here to help.