iOS Privacy settings in 16 incompatible with S2 and Sonos - accepting the privacy risk required to use S2.

  • 8 June 2023
  • 2 replies
  • 62 views

My iPhone12 is “unable to connect to Sonos” using the s2 app.

After calling in to the Helpdesk I learn that my Sonos Play1 is online, connected to the Wifi network, and it on the same network as my iPhone. However, the S2 App cannot find it because the “Limit IP Address tracking” option, which is primarily for Mail and Safari, is switched on.

When I switch this selection off the “Private WiFi Address” selection automatically switches on.  The iPhone system toggles between one of the options being on for at least one round, until I can finally switch them both off. And, when I switch both of them off, then my iPhone gives me notice of a “Privacy Warning.”  

The Helpdesk agent informed me that the Sonos cannot be accessed if I am using either of the privacy settings on my phone, even without a VPN.  

I am saddened as it seems the only way to use this device is to expose my phone or other iOS device to privacy risks.  

Is there anyway around this.  Can’t I just bluetooth connect them?   

The Helpdesk agent could not advise me on Bluetooth, but this seems like a simple solution. 


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Userlevel 7
Badge +23

Get a better router. If the “limit ip tracking” has to be disabled for your Sonos to work, your router isn’t smart enough.

Userlevel 7
Badge +17

Your Play 1 does not do bluetooth……