I can no longer see new additions to My Music personal cloud

  • 1 February 2024
  • 1 reply


I have had my domestic Sonos system for the past decade, linking to a steadily growing digital music folder on a Seagate NAS.  

I have the app loaded on a Samsung S23 Ultra, an HP All in One operating WIN10, an MS Surface Pro running WIN11 and a Kindle Fire.

In January I added seven albums and although I can see that they are in place, in the standard WMA format, with all supporting data as required (Windows Media Player is my main ripping tool) Sonos is NOT seeing them no matter how many times I do a Music Library Index update.

I went online and saw that there is a track count limit (65,000), I am at 26,100...I saw there was an unspecified memory limit and had a look at my file sizes, deleting a number from my registry where they appear to have been too large by comparison to other similar recordings to free up memory but that made no difference.

I deleted and reloaded the app on all devices, and have ordered the Library update from each controller separately. None has worked to give me access to the added files.

The only other change I’ve made is to swap out McAfee for Norton - I had some online and dial up support from Sonos but that was inconclusive, suggesting I need to talk to Microsoft and /. or Norton.

Anyone else had experience like this, and if so did you manage a fix without having to talk to either  of those companies support arms?


Best answer by Jamie A 2 February 2024, 16:24

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Userlevel 7
Badge +16

Hi @Spursyid99

You are correct that we have a track limit of 65,000 and this limit can be reached by both track limit and memory usage. To reach the memory usage limit, you’d need tracks with a large amount of metadata, something which is common in classical music for example. It’s also happens that tracks that are missing metadata wont show up when you search for specific albums or artists. I would recommend using a library management tool to check the metadata of your tracks to make sure everything is in order.

While DRM is most commonly found with tracks purchased from iTunes before they switched to DRM free music, music acquired from other vendors may also have DRM. It’s worth checking if the tracks you have added have DRM which is preventing you from adding them to your Sonos library.

I don’t think talking to Microsoft or Norton will help unless they’re blocking the Sonos app via the firewall, or through something else. As you’ve already tried to re-index and removing tracks, then if the above doesn’t help I would recommend reaching back out to support again. If you do reach out, it’s better to go through the phones in this case as our team will be able to remote into your system to see what could be causing the issue and how to resolve it.

I hope this information helps!