Cannot mount SMB share

  • 7 April 2021
  • 9 replies
  • 348 views

Hi everyone,

I’m completely disappointed about my problem. I want to mount a share into my sonos app but I don’t find the solution.

 

System : Synology NAS
Sonos App: S2 on Android and Windows (same problem!)

Error: it depends the configuration (because I tried many thing). Mostly it’s “Connection refused”.

URL: \\192.168.1.100\mymusic
Username: sonostest
Password: simple password like 1234567890

Actions I did:

  • Enable SMBv1 to SMBv3
  • Disable Firewall
  • Tried to mount on Windows the share with the same username/pwd: OK
  • Tried to mount on my Android the share with the same username/pwd: OK
  • Mount with account with “admin” right: Failed
  • Guest account, without password: Failed

Mobile/Windows:

  • No VPN
  • Same network
  • No specific configuration (like Domain)

I read many posts about this problem but unfortunately, it doesn’t work for me

Thanks for your help


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

9 replies

Userlevel 7
Badge +22

 

Try the mount again, submit a diagnostic within a few minutes. Post the diagnostic number here or call Sonos and have then assist you. The diagnostic contains information we users can’t see.

==> Which kind of “diagnosic” do you mean ? Are talking about a tool ?

Thanks

 

Sonos controller menu option: https://support.sonos.com/s/article/141?language=en_US

Have you tried browsing to the share, rather than adding it using text?

Not sure to understand. As far as I known, you cannot do it from Sonos S2 app, but if I use another app in my cellphone, it works.

I also tried through DLNA, but sonos app doesn’t see my Syno

DNLA is a different system….

I mainly use the PC app when I can. If I go through Manage/Music Library Settings and then press Add then I get a screen that allows me to choose NAS. I am then offered a screen to input the share name, which has a Browse button to the right of it. Clicking on this takes me to a standard WIndows browse pane, from which I can select the network share.

Have you tried browsing to the share, rather than adding it using text?

Not sure to understand. As far as I known, you cannot do it from Sonos S2 app, but if I use another app in my cellphone, it works.

I also tried through DLNA, but sonos app doesn’t see my Syno

Have you tried browsing to the share, rather than adding it using text?

Hi,

Thanks for your answer.

My address starts off //mediaserver (rather than IP adress)on my WD NAS. 

Double check you definitely are on SMBv1 in NAS settings.

==> Already tried and SMBv1 is enabled (unfortunately….)

Try the mount again, submit a diagnostic within a few minutes. Post the diagnostic number here or call Sonos and have then assist you. The diagnostic contains information we users can’t see.

==> Which kind of “diagnosic” do you mean ? Are talking about a tool ?

Thanks

Userlevel 7
Badge +16

My address starts off //mediaserver (rather than IP adress)on my WD NAS. 

Double check you definitely are on SMBv1 in NAS settings.

Userlevel 7
Badge +22

Try the mount again, submit a diagnostic within a few minutes. Post the diagnostic number here or call Sonos and have then assist you. The diagnostic contains information we users can’t see.

My objective is to have everything on my NAS and the music is available for everyone in the network. For example, my wife can access even if my laptop is shutdown from her cellphone

Userlevel 7
Badge +23

Can you not just put the files on your Windows device and skip the NAS entirely?