Answered

Unable to connect to Sonos

  • 4 December 2020
  • 18 replies
  • 1082 views

Hi Sonos community.

My iphone only connects to sonos about 20% of the time. The rest of the time is says “Unable to connect to Sonos product”.

I’ve tried resetting the app, restarting my router, switching all router traffic to 2.4GHz, re-installing sonos app on phone, setting the iphone ‘local network’ on, restarting my phone.

The thing I really don’t understand is my wife’s android phone has no trouble connecting to Sonos - works 100% of the time. It seems to be a problem with the iphone only (iphone 11, ios14.2)

Any ideas wd be very much appreciated! 

icon

Best answer by BernHu 31 December 2020, 05:57

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

18 replies

Perhaps try switching off ‘Private Address’ in your iPhone WiFi Network Connection Settings and see if that fixes it. I’ve read that the new ‘MAC Address Spoofing’ is causing some issues with some routers, particularly those that have older firmware.

Hope it resolves the issue for you.  

 

https://mb.com.ph/2020/08/14/protecting-your-home-network-from-ios-14s-private-address-feature/

 

https://haasentertainment.com/beware-of-private-wi-fi-address-feature-in-ios-14/

Ken_Griffiths, you are an absolute STAR.

I split the wifi into 5GHz and 2.4 GHz bands, connected the iphone/sonos to the 2.4GHz AND turned off the ‘Private Address’ as you said, and it’s been working fault free for 2 days now. I can now play cheesy christmas tunes to my heart’s content! Thank you and happy Christmas!

 

@Ken_Griffiths you an absolutely star, I’ve had Sonos for 5 years plus and usually can fix issues myself but I’ve not been able to work this out and it’s been driving me nuts to the point of wanting to throw the lot out of the window, didn’t think to check on here!

 

For info to anyone else with the same problem, I didn’t need to splt the 5 & 2GHz bands, just on all iOS devices turn off “Private Address” and we are all now on the cheesy Christmas tunes along with @JJ_2000 

 

@Sonos Just a suggestion, when something like this type of problem with a major app arises, it may be worth sending an email out to users for the fix as this has been a issue for me since the iOS update, but didn’t know about the “private address” thing. I’m sure there are a number of people having issues that wouldn’t log in here to find out what to do.

 

Anyway, thanks all, really apprecaited!

 

I also get ‘Unable to connect to Sonos Learn more’ after I successfully install the Boost.

I have the Boost and Sonos One. The Boost is connected via Ethernet and Sonos One speaker is wireless. I have an Android phone.  

 

I also get ‘Unable to connect to Sonos Learn more’ after I successfully install the Boost.

I have the Boost and Sonos One. The Boost is connected via Ethernet and Sonos One speaker is wireless. I have an Android phone.  

So did you have the Sonos One setup and working originally ...and then did you add a Boost and suddenly lose your speaker/setup?… Can you perhaps just briefly describe the steps you have gone through so far.

@Ken_Griffiths you an absolutely star, I’ve had Sonos for 5 years plus and usually can fix issues myself but I’ve not been able to work this out and it’s been driving me nuts to the point of wanting to throw the lot out of the window, didn’t think to check on here!

 

For info to anyone else with the same problem, I didn’t need to splt the 5 & 2GHz bands, just on all iOS devices turn off “Private Address” and we are all now on the cheesy Christmas tunes along with @JJ_2000 

 

@Sonos Just a suggestion, when something like this type of problem with a major app arises, it may be worth sending an email out to users for the fix as this has been a issue for me since the iOS update, but didn’t know about the “private address” thing. I’m sure there are a number of people having issues that wouldn’t log in here to find out what to do.

 

Anyway, thanks all, really apprecaited!

 

Hi Pete, 

I’ve just got a Sonos Symfonisk speaker and it is driving me nuts. The solution to turn off the “private address” got me excited and it did worked for less than a minute (which is a big discovery for me)  but I’m back to square one again :( 

 

Any other suggestion for me to try? 

 

 

I’ve just got a Sonos Symfonisk speaker and it is driving me nuts. The solution to turn off the “private address” got me excited and it did worked for less than a minute (which is a big discovery for me)  but I’m back to square one again :( 

 

Any other suggestion for me to try? 

This sounds like a different issue to those mentioned earlier in the thread and sounds like it might be a network issue. Perhaps see if this video in relation to WiFi interference may assist you to solve the issue:

Wireless Interference and Sonos

Hi Ken, thanks for sharing the video. I’ve tried that and putting it into different channels 1-6-11 and factory reset the device each time and still disconnects halfway playing songs (always before the first song ends) Should I try to separate 2&5GHz ? 
many thanks

Hi Ken, thanks for sharing the video. I’ve tried that and putting it into different channels 1-6-11 and factory reset the device each time and still disconnects halfway playing songs (always before the first song ends) Should I try to separate 2&5GHz ? 
many thanks

Maybe before you choose that (often helpful) option BernHu, perhaps just ‘briefly’ describe your network and Sonos setup and then see what might be the best things to try.

  • Make/type of router and channel(s) in use (channel width)?
  • Network switches (if managed)?
  • Other WiFi Access points?
  • Sonos Products (how many - if wired to LAN, or not) (SonosNet Channel)?

Thanks.

Hi Ken, 

It’s got worst now. Could not detect Sonos, can’t even play a song now. 
 

My device model is Huawei B818-263 and I have manually set it to channel 6. No network switches or other WiFi Access points as we connect direct to this modem. The Sonos Product - Ikea Symfonisk. 

 

Current setting 

  1. 2.4 GHz and 5 GHz signals are combined and displayed as one. 
  2. Security Mode - WPA/ WPA2-PSK
  3. 2.4GHz - Bandwidth: 20MHz, Channel 6; 5 GHz Bandwidth: Auto, Channel: Auto. 

Many thanks again for your help. 

Try the 2.4ghz Band on Channel 11 ...and 5ghz Band on Channel 36 instead of Auto… leave the channel width set to auto too on the 5ghz band.
 

If that doesn’t work then try splitting the bands and name them differently, something like ‘MyNetwork-2G’ & ‘MyNetwork-5G’ just as examples.

 

If you do change/rename the 2.4ghz band, then you need to temporarily wire the symfonisk speaker and update its stored WiFi settings too. That’s done via the Sonos Controller App by going to “Settings/System/Network/Wireless Setup” and entering the 2.4ghz credentials (SSID/Password) which are case sensitive - when complete, you can uncable the speaker and it will then run on your WiFi.

Hi Ken,

Ive tried to manually fixed the 2.4and5GHz channel as recommended but it is not working.

I was checking on the modem to see if Sonos is connected and I found Sonos is on 2.4GHz but all you other devices - ipad, iphones, mac, google home on 5GHz. Could this be the problem? (see attached screenshot) 

A bit reluctant to separate 2.4&5GHz tho.  

Hi Ken, can the Sonos be connected using 5GHz? Or it needs to be on 2.4GHz?

Hi Ken, can the Sonos be connected using 5GHz? Or it needs to be on 2.4GHz?

Sonos units do connect to 5GHz.

Home theatre satellites all use 5GHz connecting to the HT main player. Also, selected units can use 5GHz WiFi, they are One (Gen 2), One SL, Port, Five, Sub (Gen 3), and Move. The others use the 2.4Ghz band.

 

This may ‘likely’ not apply in your case, but some routers can ‘isolate’ communication between the 2.4Ghz band and the 5Ghz band. The routers that combine both, often don’t isolate and should sort out which band the connected device requires, but occasionally they may work better, in some instances, if the bands are separated by giving each band a different SSID name, something like ‘MyNetwork-2G’ and MyNetwork-5G, just as an example.
 

The decision to separate/rename the bands is upto you, bearing in mind that you may have to re-attach all wireless network devices on your LAN, if you choose that option and decide to stick with it setup that way. I have chosen to separate/rename my wifi bands on a D-Link dir-2660 router. Maybe consider it as a last resort if you can’t get things to work correctly.

Userlevel 2
Badge +4

@Ken_Griffiths you an absolutely star, I’ve had Sonos for 5 years plus and usually can fix issues myself but I’ve not been able to work this out and it’s been driving me nuts to the point of wanting to throw the lot out of the window, didn’t think to check on here!

 

For info to anyone else with the same problem, I didn’t need to splt the 5 & 2GHz bands, just on all iOS devices turn off “Private Address” and we are all now on the cheesy Christmas tunes along with @JJ_2000 

 

@Sonos Just a suggestion, when something like this type of problem with a major app arises, it may be worth sending an email out to users for the fix as this has been a issue for me since the iOS update, but didn’t know about the “private address” thing. I’m sure there are a number of people having issues that wouldn’t log in here to find out what to do.

 

Anyway, thanks all, really apprecaited!

 


In addition, it would be nice if Sonos actually informed their tech support workers when pretty standard problems like this pop-up. I wasted about 2 hours on the phone today trying to figure out why my WiFi kept dropping-out with my newly-acquired Sonos Beam. It’s a bit ridiculous that none of the three tech support workers had a script to run-from, in regards to a known iOS 14 issue affecting WiFi connectivity. Granted, we’re in holiday season, and maybe they were outsourcing their calls to temporary workers who don’t have access to the full tech support database. But still..   (I’m currently enjoying the Third Man radio station over an ethernet connection. So I don’t want to harsh my buzz by trying WiFi again, using this new iOS 14 privacy adjustment—but I really do hope it works later tonight).

Hi All, 

Just an update to all, I have contacted Optus, Huawei and Sonos. In conclusion, I am unable to get my Sonos Symfonisk playing songs with my wifi modem. I also got confirmation from Sonos in regards to this as my modem is a portable 4G modem and my 2.4ghz connection isn’t stable (5GHz works fine with more than 100mbps). The Sonos can still connected via wifi to my modem (confirmed as I can see it connected) but just that it can’t play a song (at most maybe 10-20 seconds) before it stop (lack of data?). My modem model is Huawei B818. 
 

Solution: I have relocated my Sonos in my living room nearer to a wall telephone cable port and have it connected via Ethernet cable while my modem is setup in the reading room. Happy days since. 
 

Hope this help if anyone facing the same issue as I am. 
 

Thanks Ken for helping and happy new year everyone. 

Happy New Year too BernHu.👍

The “Use Private Address” toggle in iOS was the source of an extremely annoying and long-lived problem.  Sonos customer service pointless.

TYVM for this thread.