Mac OSX 12.4 desktop app crashes on launch

  • 21 June 2022
  • 7 replies

The app stopped connecting to my Sonos speakers yesterday, don’t think I performed any updates. It just goes to “Not responding” immediately. I tried resetting the app and when I hit “Connect to existing speakers” it again locks up “not responding”.

When you reopen the app, if you click on any button, it stops responding.

It generates a report to send to Apple which doesn’t make any sense to me.

the iOS Phone app and iPod app works just fine on the same network.

Any ideas? It’s unfortunate that these Sonos devices continue to have problems, I really like them. But for the price I would think they could perform at least as well as an Echo device which pretty much works seamlessly.


Best answer by Airgetlam 23 June 2022, 19:34

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

Nevermind, it’s a VPN issue, now I have to figure out how to get around this. It has been working just fine forever with the VPN… 


Same VPN issue here.

Sonos doesn’t work with VPNs. VPNs are generally designed to allow a single device (your computer) to communicate with an outside server. Sonos requires communication between your mobile device and the speakers, and the outside streaming company’s server. 

Sonos has some FAQs, I think, in order to set up specific VPNs, but not by any stretch all of them, since there are probably dozens, if not hundreds of variations, including non-standard setups.

Your best bet is to figure out how to operate without a VPN when using Sonos, and with a VPN the rest of the time. 

Userlevel 7
Badge +23

A VPN that lacks a split-tunneling option should just cause the Sonos app to not find any players, it should not cause it to hang. This isn’t the first report of a Mac VPN causing this, so I guess something is weird about Mac VPNs compared to PC ones.

Thanks for the primer on VPNs Bruce, already knew that. Just odd how it’s been working fine for several years and all of a sudden, this week, it decides not to play nice.

I’ll definitely check out the FAQs when I feel the urge and can stir up the motivation. Just getting tired of having to root around for solutions that should be intuitive IMO. 

I never have these problems with the Echo devices on my network. Guess I should just switch to those eventually (if I didn’t have so much $$$ invested in Sonos gear) and move on with my life. 

It’s not uncommon for lots of apps, including VPNs (and TVs, cable boxes, Amazon devices, etc. for that matter) to update themselves without specific call outs to the user, unfortunately. Where I can, which isn’t everywhere, I do my best to keep things from auto-updating, so I can isolate issues to a specific thing.

My current guess is that your VPN  application changed its own settings, which caused the issue with your Sonos devices. Not the fault of Sonos, unfortunately. But I certainly agree, incredibly frustrating for something to have worked for so long and suddenly everything changes for the worse. 

I agree - this is a bug that affects the apps ability to reconnect once it has gone on/off vpn. It not working while on VPN could be expected without a provide enabling split tunneling - this is not that though.


  I opened a ticket with support and am happy to produce dumps needed to fix the sonos network stack so it can not hang.