Sonos Move suddenly has Alexa problems

  • 5 June 2023
  • 5 replies

About 2 weeks ago our Sonos Move that we have been using with no problem for 2 years suddenly stopped executing Alexa commands. It would repeat the command but do nothing. I updated all the apps on my Apple phone, reset the Move, removed and re-added the Sonos and Alexa voice services. Now instead of not doing anything, it decides what it wants to do. Sometimes it works fine. Other times we have to pause it before it will follow a command. Other times it just does nothing. Any thoughts?

5 replies

I am experiencing the same problem, and have also tried the recommended fix repeatedly with no success. My sonos One speakers will respond whenever I ask Alexa for anything other than music.  When I say “Hey Sonus play music” it works, but when I say “Alexa play music,” I get only silence. Also, my Echo Dot will no longer control my Sonos 5 speaker (no internal Alexa).  I am concluding that this is by design. The Sonos website says that you can use Alexa for voice control of devices, but doesn’t say it can be used to play music.  What I find particularly annoying is that Sonos voice control is not nearly as good at finding artists as Alexa, even though it is supposedly searching the same Amazon Prime Music library.  If I ask for Delbert McClinton, it plays Don McLean.  Perhaps Amazon no longer allows Sonus to use Alexa voice controls to stream music, since Sonos has introduced their own music service.

Userlevel 2

I tried the suggested solution above but it does not work. I tried factory resetting my Move as well. Alexa will respond "Playing...." after I ask but it is followed by silence. Alexa doe not respond to volume change voice commands either, along with many other commands. This is really disappointing :(

So, what did Sonos Support suggest, when you contacted them?

Userlevel 4
Badge +2

Same issue on my Arc - I’ve already tried to disable/enable the skill plus MANY other ts steps. Seems there are a few other threads with similar issues as well...

Userlevel 6
Badge +14

Hello @Lardman, welcome to Sonos Community!

Please have a look at the following support article Alexa commands not working on Sonos. The below troubleshooting step is usually the easiest and fastest fix, as it refreshes the connection with the Amazon Alexa cloud.

Re-enable the Sonos skill

Open the Alexa app and tap on the More menu in the bottom right. Tap on Skills & Games → Your Skills →  Sonos →  Disable Skill. Once disabled, tap on Enable Skill.

Let us know if this fixed your issue and if you have any further questions feel free to reply.

I hope this helps.