Answered

Alexa wont play music from Tune In

  • 3 June 2023
  • 5 replies
  • 1281 views

This has only started happening recently where I ask Alexa to play a certain radio station or stations from tune in and her prompt is “sorry I am having trouble playing the music “. I’ve updated Sonos and the app . I’ve reset my network setting . I’ve reset the speaker . I’ve updated  Amazon Alexa . Still not working . Not sure what else to do . 

icon

Best answer by Corry P 5 June 2023, 13:14

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

That did the trick ! Thank you very much 🤗

Userlevel 7
Badge +18

Hi @sephero 

After I did this, I now have two versions of my device in Alexa’s device list - one from enabling the voice service through the app, the other from doing the above. Is this expected?

I would say no - you should be able to deregister any phantom devices from within the Alexa app - Alexa app » Devices » All devices » [name] » [Trash bin] (top right corner). Or, remove both, then ask Alexa to “discover devices”.

Why does the device detected through the in-app Sonos flow, not automatically know how to play music services?

I’m not quite sure what you mean by this. In order for an Alexa command to play music to Sonos, both Sonos and Alexa must typically have the same music service account added. TuneIn has changed recently, however - I’m not sure if Alexa behaviour has changed any in relation to TuneIn.

If the above steps did not help whatever issue with Alexa you are experiencing, I recommend you get in touch with our technical support team who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports - there are some more involved steps that we can guide you through.

I hope this helps.

Userlevel 7
Badge +18

 Hi @Sean6253 

Welcome to the Sonos Community!

Please try disabling and re-enabling the Sonos skill in the Alexa app: Alexa app » More » Skills & Games » Your Skills » Sonos » Disable Skill then Enable to Use.

I hope this helps.

 Hi @Sean6253 

Welcome to the Sonos Community!

Please try disabling and re-enabling the Sonos skill in the Alexa app: Alexa app » More » Skills & Games » Your Skills » Sonos » Disable Skill then Enable to Use.

I hope this helps.

 

After I did this, I now have two versions of my device in Alexa’s device list - one from enabling the voice service through the app, the other from doing the above. Is this expected? Why does the device detected through the in-app Sonos flow, not automatically know how to play music services?

 

Thanks!

Userlevel 7
Badge +18

Hi @Sean6253 

Glad to hear it, and thanks for updating the thread!