Wired Play:5 is not requesting an IP address over DHCP, but has link and sends BPDU/STP messages

  • 10 September 2023
  • 3 replies

Userlevel 2

I have seven devices running on Sonos S1, even some quite old ones, from the early days. I am an Sonos early adaptor and started with Sonos in 2009. I have multiple Play:5 1st gen and some newer devices, that despite they could run S2 still run on S1, because of compatibility.

After I relocated from a flat into my new house, I am not able to get two of the 4x Play:5, that I own, back online again and connected into the Sonos mesh.

With relocation the network infrastructure changed from one connected Boost on an unmanaged switch (AVM FritzBox 6360 with integrated Access point) to a fully managed infrastructure with managed Zyxel L3 switches (XMG1930 and XS1930) and dedicated Zyxel access points (NWA210AX), which allow fine grained configuration of VLANs, IGMP Snooping and also support RSTP and MSTP and fortunately also port mirroring for observing what happens.


To avoid network loops and as I have a lot of concrete and steel in the house and SonosNet would anyway not work, I decided after some heavy broadcast storms, that I will wire all players and disable SonosNet and WIFI on all players. This is also done for all working devices. To my knowledge that should be fine and possible also in general.

4 players are working fine.


But now the problem starts: 2 of the Play:5 do not integrate. When I connect them to power and to the LAN ports, which are identically configured (VLAN, IGMP Snooping, MSTP settings) like all others, they are not found. Also not when I factory reset them again.

Technically they seem fully working. I can reset them to factory state, LED indications make sense at every time, I can observe Layer 2 BPDUs coming from the device, they output the sound when starting discover mode over button press, so they seem technically fine and not broken (e.g. damaged power supply, what I had in the past with a old Sonos Connect, which did not start anymore).

So the missing Play:5 seem to boot, seem to communicate on Layer 2 on the network. I can observe STP/BPDU communication packets with the MAC address of the missing Play:5 in the packet traces.

What I never see is a DHCPDISCOVER request. So the Play:5 never requests an IP-address. I also see no request on the Router serving DHCP and answering the DHCPDISCOVER with an IP.

They then of course also do not join the multicast addresses, what the working ones do. I can see that on the switch, that the missing Play:5 never joined.


I also tried already to just put them on another switch port, where a working Sonos player is connected to exclude this dumb case, but that also did not change anything.


How can I fix or address that?

What can be the reason for that, so that the players do not request an IP?

Do I have any way to get insight what happens on the player? (as they do not have an IP, I cannot access the hidden web frontend on port 1400 to look into network and stp state).



Best answer by ratty 11 September 2023, 18:52

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

What if the Play:5 is wired to any other router? Does it get an IP then? A basic wireless router, cascaded off the main network, would do for this experiment. 

If it still won’t get an IP I think you’d need to speak with Sonos Support. 

You have 2 Play:5/Gen1 which evidently work fine. Presumably they’re wired.

See what happens if you wire the two ‘awkward’ Play:5s to the second Ethernet ports of the ‘good’ Play:5s.

Userlevel 2

I already tried that, but it did not change anything.

I connected one of the non-working Play:5 to the 2nd unsused Sonos Port network port. But also did not change anything :(


Other ideas?