Sonos and Meraki

  • 12 September 2013
  • 5 replies

Userlevel 2
We have been long time users of Sonos equipment and it has worked flawlessly behind all of our previous routers at our locations. We have recently implemented Meraki MX90 and MX80 firewalls/routers at our main location and branch locations. After doing so we are no longer able to use the Sonos equipment. I can see the device on the network but can not connect to it and it doesn't connect out to the internet. I have enabled all the required ports, have whitelisted the device in the Meraki, and we still get nothing. Surely in all the Sonos world someone has come across a Meraki frontend...Any help would be appreciated.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Userlevel 4
Badge +14
I think you need to provide a little more info in order to answer your questions.

Schematics, what type of controllers, which IP networks each device resides on etc.

You say that you can "see" the players on the network, that doesn't really tell us anything. How do you "see" them, apparently not in the controller.

UPnP (which Sonos utilizes) was never really intended for enterprise networks, and as soon as you try to secure your network, you will bring problems to UPnP discovery etc.
Userlevel 2
ISP--> Meraki MX90 -->SonosZP

ISP--> Meraki MX80-->SonoZP

Each branch has there own IP scheme the Sonos devices are grabbing x.x.x.252, 253, 254 at each branch via DHCP.

I can see the Sonos device in the DHCP tables of the respective 90 and 80 devices.

When I press the Mute and Volume up on the Sonos and Launch the controller either via idevice app or Windows it will begin searching for the device but never locate it.

Watching the device on the Meraki dashboard you can see it come "online" grab an IP address then it just sits there doing nothing on the network.
Userlevel 4
Badge +14
Are you expecting to be able to control all players, on all branches, from all branches?

Please state the IP-network assigned to the machine that runs the desktop controller, and on the mobile device, and one IP-adress from the player.

It's the first 3 blocks of the IP that are relevant, not the last one.

e.g: 192.168.12.x

Usually the problem lies with multicast and broadcast traffic being blocked. That is required for association and locating the players when the app starts (broadcast for vol+ and mute, multicast when you start the controller after you've associated it).

This is what I had to do in our office to get a semi-functional setup across different networks.
Hi Erick,

I had to set my Meraki AP to “bridge mode”, which can be considered a security threat, but was necessary. I had no changes necessary at all within my MX Security Appliance.

I hope this helps, Erick. If not, please feel free to respond here. 🙂
Userlevel 7
Badge +22
Last post was five years ago... The forum is not helpful is making that obvious.