Some Sonos speakers won't join Google Nest Pro network

  • 11 February 2024
  • 20 replies
  • 118 views

Like many others, I’m having difficulties connecting my Sonos speakers to a Google Nest Wifi Pro mesh network.

My Arc, Move, Five, and Amps are connected fine.  My Sub and two Ones aren’t.

Tech support had me factory reset speakers, reconnect them, restart my Nest routers, round and round for about 5 hours, and eventually everything connected.  That was two weeks ago.  Today the Sub and Ones are off the network again.  I factory reset them and tried to re-add them but that failed.

I’ve read the threads on this topic but they are all closed so I thought I would start this new one.

Here are a couple details I think make my situation particularly difficult:

  1. Not all of my Sonos are close enough to each other to see the Sonos network, so I can’t rely purely on SonosNet.  Instead, I have wired two Nest routers to each other over a long distance.  All Sonos can therefore see my wifi network.  I also have Nest routers that are not wired together.
  2. None of my Sonos are close enough to the primary router to be wired to it in normal use.  (But I’m not sure this would help anyway given point 1.)

My Arc/Sub/Ones are close enough to a Nest router that one of them could be wired to it, but it is not the primary router.

Thanks for any advice.

My advice to others is:  Do not buy the Nest Wifi Pro.  Even if you don’t use Sonos, is it is a very buggy router, not at all like the previous Google Wifi, which was rock solid.  The Nest Wifi Pro often picks a device it hates and won’t let that device connect for days or weeks at a time.  Eventually it will let that device connect and will pick some other device to hate.  I’m in a rural area with very low interference.  It is very clearly a software bug because often the hated device can still connect to the guest network.

I’m putting this under “Advanced setups” because anything involving Nest Wifi Pro is somewhere between “advanced” and “hopeless”.


20 replies

The Nest Wifi Pro often picks a device it hates and won’t let that device connect for days or weeks at a time.  Eventually it will let that device connect and will pick some other device to hate.

 

Could you be running out of IP addresses in the DHCP pool?

How would I check that?

You’d need to look in the DHCP server settings for the Nest primary. Do you have a lot of devices on your network? 

This might get you to the right place: https://support.google.com/googlenest/answer/6274660

The Home app shows 26 connected devices, less than the 100 that a Nest Wifi Pro is supposed to handle (according to a quick google search).  So yeah, that’s quite a few devices.

26 devices is not a lot. If the pool size is not the problem you could try experimenting with IP reservation for all your Sonos devices. The above link describes how.

Sonos support recommended that I call back tomorrow.  They have tools that they can only use on weekdays.  But that would require me to take a day off work, and I’ve already put 9 hours total into trying to get this to work, so I think it’s time to call it quits.

Can anyone recommend alternative brands of speakers or routers that are known to work?  I could perhaps replace just my Arc, Sub, and Ones with a different home theater setup.  Or I could replace my Nest wifi mesh and reconnect all devices to that new network.

I run my system on an ASUS ZenWiFi mesh.

Sometimes when trying to add a Sonos product it will complain that my phone is on the Foobar network, while the Sonos product is on a different network, also called Foobar.  So I think the root of the issue is that Sonos thinks there are two networks, both coincidentally having the same name, while all my other wifi devices think of there as just being one network.

I might give the ASUS network a try.  I really don’t look forward to setting up all my Nest thermostats, laptops, chromecasts, etc, all over again.  But the only alternative I see is to toss my Sonos speakers and try a different brand of smart speakers, which would also be a massive hassle.

Userlevel 7

I also you Asus ZenWifi Pro ET12 x 3 with a wired Backhaul. I had Bestbuy Geek Squad run the Ethernet wire and install wall mounted Ethernet connection plates. Some of the Ethernet (weather rated) was run on the outside of my home. That was 3 years ago.

FYI, I have 32 Sonos products, 10 cameras , 4-5 appliances, 4 TV’s, 4 AppleTV 4K boxes, 3 computers, cell phones, tablets, security system and other things on my network. Knock on wood it’s rock solid 😉

Note: I can see at least 20 other networks near by. 😂

I might give the ASUS network a try.  I really don’t look forward to setting up all my Nest thermostats, laptops, chromecasts, etc, all over again.  

When I first installed the ASUS mesh -- which is a triband with wireless backhaul -- I split the bands and configured SSIDs/passwords that matched the original disparate collection of router/access points. The Sonos system (and everything else) just reconnected when I powered it up.

The subsequent bit of tweaking to bind Sonos units to specific nodes and corral units using per-band access control could be regarded as optional.

Userlevel 7

@quasar 

To further negate connection issues use the same SSID and password. WiFi devices and Sonos are not looking for router hardware brand..,just the SSID.

I suspect this might be related: https://partnersupport.plume.com/s/article/Unstable-networks-caused-by-improperly-connected-Sonos?language=en_US

So it seems some configurations of Plume exhibit the same issue as Nest Wifi Pro.

I suspect there’s a loop in the network, related to the mix of wired and mesh in my network, and the Spanning Tree Protocol that Nest uses in its SonosNet.  If Sonos thinks the Foobar network isn’t the same as the Foobar network, when in fact it is the same, voila, a loop is formed instead of a tree.

If none of your Sonos units are wired then SonosNet and Sonos’ flavour of STP are inactive. 

Ah ok.  So I guess Sonos just can’t connect to this brand of wifi sometimes, for unclear reasons.  And only certain models of Sonos.  My mind boggles at how such a bug is even possible.  But I guess the protocols for negotiating bands and channels and so on are complex, and none of it is logged anywhere, so there’s no opportunity to look and see, “Oh, there’s where a mistake was made.”

You might refer to the Sonos Network Requirements FAQ, too.

Here are the supported WiFi modes/bands.

https://support.sonos.com/en-gb/article/supported-wifi-modes-and-security-standards-for-sonos-products

Those pages don’t predict my issues because the Move works fine, while the One SLs don’t.

Had similar issues when I upgraded to Google Wi-Fi Nest Pro from older version of their mesh system…been pulling out my hair trying to connect my Sonos system via Wi-Fi…today I opened the Sonos app and tried to play music with the speakers in my ceiling and could not connect…I restarted entire network, unplugged the amp and all the speakers then once my Wi-Fi was up and running I plugged everything back in and my app was able to find my speakers and I followed prompts…I relinked my speakers and my play bar followed along. It is all connected now. I noticed before I started all this today that the ACCOUNT, SYSTEM and SERVICE & VOICE on the Sonos app were all light grey and I couldn’t change access anything…I hope this helps someone. I am no tech expert but somehow its all working now and hopefully it will continue

The reason all those ‘services’ were grey is because they exist on the system running on your speakers. When the controller (mostly just a remote control) can’t contact the speakers, it’s unable to present all of those ‘features’. 

Reply