Answered

tp-link deco S4 mesh

  • 7 March 2021
  • 5 replies
  • 87 views

I have installed a tp-link deco S4 mesh network  and have now lost connection to my three Sonos speakers. I’ve connected one of the speakers via Ethernet to the main S4 unit which is connected to the router. 
getting a wee bit vexed/stressed. Wifi is excellent throughout house now and was hoping for a simple reconnect for the Sonos speakers. 
Are there any not too techie ways of resolving this? I’ve seen a couple of threads which make some quantum leaps in assumed capabilities of the reader..

icon

Best answer by el rubio 7 March 2021, 18:55

@ChrisBH great to hear you fixed the issue - just keep in mind that any active wifi signal from another router will cause interferences to you actively used signal, so if you have no particular need for the Virgin router’s wifi then you should opt to disable it at some time :wink:

 
View original

5 replies

Is the WiFi on your router enabled or disabled? (It should be disabled.)

Is any other device besides the S4 main unit wired to the router? (The S4 main unit should be the only device wired to the router.)

Is your controller device connected to the Deco WiFi? (If the router WiFi is disabled then it will have to be)

Hi John B

I saw in another thread something about changing the Deco set up from the default router setting to Access Point in the Advanced/Operating Mode menu.  Do I did and to my amazement and joy (and tbh bewilderment about the difference i triggered in the Deco set up) the Sonos units all came back to life again. 
The Virgin router is still emitting a wifi signal but my various bits of kit are now working and the signal remains strong throughout the house.  

If I’m brave/bored enough one day I might turning off the Virgin wifi but for nowI will count my blessings and stop there.

Thanks for responding though.

@ChrisBH great to hear you fixed the issue - just keep in mind that any active wifi signal from another router will cause interferences to you actively used signal, so if you have no particular need for the Virgin router’s wifi then you should opt to disable it at some time :wink:

 

Hi John B

I saw in another thread something about changing the Deco set up from the default router setting to Access Point in the Advanced/Operating Mode menu.  So I did and to my amazement and joy (and tbh bewilderment about the difference i triggered in the Deco set up) the Sonos units all came back to life again. 
The Virgin router is still emitting a wifi signal but my various bits of kit are now working and the signal remains strong throughout the house.  

If I’m brave/bored enough one day I might try turning off the Virgin wifi but for nowI will count my blessings and stop there.

Thanks for responding though.

 

Update day 2. Sonos app on phone could  not find speakers again. Resolved by plugging one of the Sonos units into one of the Mesh S4 units via Ethernet cable - speakers appeared straight away. Not ideal but can live with perm cable to one speaker.

Reply